Windows out of memory

Im running rhino 5 under a windows partition on a mac (32bit). My file is 240 MB. Im building an architectural space but the file isn’t too heavy. Every time I try rendering or render preview I get the message that windows is out of memory and has to shutdown rhino then recommends a restart of my laptop. I have increased my virtual memory but it hasn’t changed anything.
I tried saving my file somewhere else on the computer and it rendered a couple of views then went back to the same message.
If anyone could help me out I’d really appreciate it. Need it for a school project due tuesday!
Thank you :slight_smile:

any way you can use 64bit rhino for rendering?
seems like that would solve your problem (assuming your computer has enough RAM in there)

@jeff_hammond I managed to switch my file over to a Dell computer running windows on a 64 bit and an 8GB RAM but i still keep getting the same message!!

hmm… yeah, then i don’t know. (and i don’t use window either)…

if you’re trying to render a large image (in pixel dimensions), maybe try something smaller just to see if you can get a render to complete without running out of memory…

that’s just a wild guess though… hopefully someone with better guesses will come in soon. :wink:

@jeff_hammond yea its weird, thanks!!

Are you able to see it in shaded views okay? How much memory is the file using in Windows’ Task Manager? If you select everything and run PolygonCount, how big is it? How big is the render you’re trying to do?

@JimCarruthers Hi Jim! Yup i can see it, I can also see it with the materials applied, just not rendered. Memory running in the Windows task manager is 942,732 K. The Polygon count is 6330480. The render isn’t big, Im not sure how to measure it for you, but I did one yesterday and it took 20 minutes. I tried saving the file as a Rhino 4, and moving to a DELL running windows on 64 bit but i still kept getting the same message, so i tried to move it to Autocad and render it there but the still got an out of memory message (on both the 32 bit and 64 bit)
Is something wrong with my file?
i’ve deleted any “bad objects” from my file but it seems to make no difference.
Thank you

Quite big would say. Seems You are using 32 Bit version of Rhino? If so, You have reached the memory limitation of the 32 bit software.

Here I posted a list of tricks:

The trick “convert all NURBS to meshes and delete the NURBS geometry from the file (for best mesh result buy MOI3D - the fastest and cleanest NURBS mesher)” can help a lot, because during rendering the scene is hold in memory several times - NURBS, render mesh for display and render mesh at the render engine. You can easy wipe the NURBS (keep a backup file). Less RAM is used if you reopen the NURBS-free file.
Also it’s possible to load an empty scene after the render button is pressed. So the render mesh for displaying is wiped too.

What is your render engine?

This I repeating a bit of @jeff_hammond but it seems like you missed some parts of the jeff’s post:
Memory consumption depends on the number of polygons in your scene as well as the pixel size of your render. Those are numbers we need to judge “how big your render” will be.

6 Million polygons is quite heavy for a render mesh in Rhino, especially if you are running a 32bit app.

You will be limited to 32bit (that means a max of about 3.8Gigs of RAM) if
a) your OS is 32bit like in your Mac configuration or
b) if your Rhino is a 32bit version, regardless of the OS being 32 or 64bit.

Since you tried to save as Rhino4 to move the file to your Dell, I would assume, your’re running Rhino4 on the Dell (?). Rhino4 is 32bit only. That would mean there is no difference between available memory between Mac and Dell. Try to use Rhino5/64 bit on a 64bit OS.

Available physical memory shouldn’t be a crash problem in 64bit. The process will just get very, very slow once the physical RAM is maxed out.

Did you check the memory consumption with the render going or before with just the file loaded?

Actually, if your OS is 32 bit (like XP) you will only get up to about 1.8Gb RAM usage before Rhino (or any other 32 bit app) crashes. No process on a 32 bit OS can use more than 2 Gb… If you are running a 32 bit app on a 64 bit OS, then you can get up to about 3.8 Gb of RAM usage.


That’s right of course, that’s why I used the words “max of”. :wink: Didn’t want to get too much into the technical details.

So i downloaded MoI but when i import my rhino file, nothing shows up in my model?? I’m just using the regular rhino renderer.

that was before, it never gives me a chance to start rendering, i get the message as soon as i hit the button, is there anything i can do to reduce the polygon count?

I’ve just tried the ReduceMesh command and its down by 20%

You can keep the Task manager open and watch the memory consumption while you start the render. Depending on your setup, you should generally see the memory indicator rise then you should get the message. Memory would be freed once you confirm the error message and Rhino gets unloaded.

If you see no increase of memory, that would mean, you hit the memory wall by just asking for the next block of memory. That seems likely on a 32bit OS with 1gig already in use by rhino alone. Then you would need about the same amount to just transfer the mesh and hit the Gigs Mitch mentioned. In that case, you would see the overall memory usage rise to about 2.5gigs before render and maybe up to 3.5 gigs while starting the render.

Anyway, if you cannot decrease the mesh size, your only way to go is using Rhino5/64bit on a 64bit OS.
On that Dell of yours are you running Rhino4 or 5?

If your Model is a Mesh to begin with, you can play with the options of ReduceMesh until your polycount goes down enough, if your model is NURBS surfaces, you can try to play with the Document Properties -> Mesh options in the options dialog to reduce polycount.

Did you try any of @Micha’s tricks apart from downloading MoI?

Ahh it got too complicated for me, I restarted it on rhino 4 on the DELL, thank you everyone!

Oookay, so you have Rhino 5, which is 64bit running on a 32bit OS. And a 64bit OS to run the 32bit Rhino4? …and you wonder why you run out of memory on both machines?

Ist not complicated at all. Just match the “bits” of OS and Rhino versions. To spell it out: Rhino5 on the Dell, Rhino4 or 5 on the Mac. Problem solved on the Dell

Hey Sara,
How Is your partition set up? R U Bootcamping or using VMwar? Bootcamp is the only way utilize all your true memory, as opposed to virtual. Run 64 bit Rhino on Windows ( 64 bit ) Partiton on the 64 bit mac and youll be good to go. Seriously consider upping your Ram! 8gigs is really minimal, especially with file sizes over 350,000 k.

Hi @Micha, in your post on the Chaos forum, you have mentioned this trick:

after the render button is pressed and the scene is loaded to the Vray engine, try to open an empty Rhino scene.

You also directed to a script whose link seems to be broken. How do I go about implementing this if I am rendering through a script? I understand the script will hold execution at Call Rhino.Command("_Render") until the render is complete so how I can execute another command that will create an empty viewport for me?