Rhino out of memory

rhino%20out%20of%20memory

I have received a message saying that rhino 6 has run out of memory.

Any ideas how to fix this or what is causing it?

Much appreicated!

Natalie T

How much memory does your computer have? Are you running anything heavy in the background?

Run the Rhino command _SystemInfo and post the results here. It’s a diagnostic and someone may be able to help you based on the information about your system.

I used to use a plugin that used to use up all the memory and force a restart. Might try checking your plugins if you have any. HTH

regards,
Sochin

Michael Pryor,

I only had GH running and Rhino. I have 16 GB of RAM installed. Its a 64 bit operating system and a x 64 based processor. This should be enough for architectural purposes, yes?

Natalie T

Thank you for your suggestion.

Thanks for your suggestion.

Add lots of those out of memory errors since around 2 weeks… something isn’t working properly but i’m not able to find a way to reproduce them

Well, with GH it’s possible to run Rhino out of memory or crash it if your definition is creating millions of objects or ones that are very data-heavy. So you cannot generalize.

In my case with 32GB without GH open a had several crashs those past weeks…

Can you repeat them in any way? Are you sure they are due to running out of memory? (i.e. don’t trust the message, go to TaskManager and verify that Rhino has really used that memory)

Do certain commands or procedures have a tendency to produce the crashes?

Might come from autosave…
I’m actually working on a 3.5Gb files already heavy which i cannot explain.
I realize that autosave files were heavily increasing (X2!! X3!!!) (see below)and probably were part of the out of memory trouble…


I had this trouble once and had to copy and paste all layers and parts in a new clean files which decrease the size by almost 3 times!! The files has already been purge.



If that helps… It’s seems it belongs to
3D Spacepilot…
Often Google Chrome crash as well with Rhino crash

RhinoOutMemory

Hello!! I have a similar issue where I get a simple “Rhino out of memory” notification and after pressing cancel I get prompted to Log In to my Rhino license but this fails and I get the error again.

This has happened just in the morning, I had no other Rhino file open once turning the computer on. Yesterday all was working fine!

I checked my disks but each has at least some 15GB free.

Don’t reply to 2-year-old threads, start a new one.

Once you get an error message like that, you should probably reboot before attempting anything else.

15GB of disk space free? That is full for all practical purposes these days.

I guess I was trying to avoid something like this (Rhino Out of Memory) although mine is not technically a duplicate. :smiley:

I have also tried rebooting, yes, I assume the other issue might be with my laptop being now about 6 years old and giving up on me, although it generally seems to work just fine!

Well I’m not sure that’s actually a Rhino running out of memory message as opposed to Chrome, so we need some more information here.

@JimCarruthers I ended up uninstalling Rhino 7 (Rhino 6 was running while Rhino 7 wasn’t) and then installing it again and it is now working!

1 Like

I have the same problem as @Emma. I uninstalled Rhino 7 then installed it again but it still doesn’t work! In the end, seems it doesn’t find the licence even if I can access my account! If I enter the licence the message is the licence is not valid!
ScreenHunter 964