Windoof Update scrumbles all sizes of Fonts, Icons in Rhino

But it seems only in Rhino.
Icons were smaller than before, text in the Layer window is not readable.
No idea what’s up.

Anybody similar experiences?
I don’t think, there’s any sense in asking Microsoft.

What Windows version? What Rhino version?

Windows 10 and Rhino WIP. Just seen, that Rhino looks as it should.


Hmm, so everything ok then?

Sorry, Rhino 6 looks fine. WIP has the fonts in the layer window very small for example.

Are you on an high DPI monitor? I don’t see difference between before and after Windows 10 update - I installed the latest feature update last week.

My Monitor is a Dell U2711 with 2540x1440 dpi.
I’ve been also wondering, what’s going on.
As you can see, everything is looking great. Except the layers in the properties window.
And the screen seems to be moved down slightly. Numbers in the small gumball input window disappear half way down.

As can be seen in the 2nd screenshot. Not only the gumball numbers are hidden half way, the gumball is very small and the rhino window is also disappearing at the lower end of the screen.
The Monitor does not allow any movement of the screen. A reset doesn’t bring better results.

Thanks !

Interestingly it shows normal HD defintion here. The reset may have also changed the resolution.

Windows shows HD defintion in the extended settings and 2540x1440 dpi in the standard window…

Rhino 6 looks pretty normal and 7 did also until yesterday morning.
Rhino 6 below. Icons on the left have different size, settings checkboxes below are visible and layers have the same font size as in the main properties window.

@BrianJ, @pascal got any idea what is going on here?

I have no ideas… I guess it would not hurt to post the results from SystemInfo in Rhino…


What is your Windows display scaling set to? Is it the recommended for your monitor?

Rhino Syteminformations:
Rhino 6 SR26 2020-5-26 (Rhino 6, 6.26.20147.06511, Git hash:master @ 7788f6214ee9335d5793cc6177985a1c745e663b)
License type: Kommerziell, Build 2020-05-26
License details: Cloud Zoo. In use by: André ()

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1070 (NVidia) Memory: 8GB, Driver date: 1-29-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 442.19

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-29-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.26.20147.6511
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.26.20147.6511
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.26.20147.6511
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.26.20147.6511
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\Calc.rhp “Calc”

The display scaling is set to 125 %.
Have no clue if it’s recomended, it worked for more than a year on this Laptop.
I’m not sure resolution the monitor is running, as windows says two different ones, as told.
Maybe a restart would at least clear this.
Thanks to all.

Hello - it is always good to eliminate third party plug-ins - odd and seemingly unrelated things can be affected - - you might try disabling VRay in Options > Plug-ins page and then close and restart Rhino - is that any different?

Also, though the driver is not quite old, it would not hurt to get the latest driver for the video card from the NVidia website.


Thanks. I will try one after another.

The one that is recommended should be listed as “recommended” in the drop down list for the display scaling percent in those Windows settings. The clipping of the whole Rhino UI makes me think this is the issue. Windows may have changed the setting on you with an update is my guess.

Thanks to all.
The update of the graphics driver solved it.

I’d still like to scale the fonts in rhino.
I tried to, but it only changes the font in the command line. The size in the windows stays.
Scaling the font by windows settings also didn’t have the desired effect.
In old windows change of all window types has been possible separately.

That’s been why I set the overall scale to 125%, also the icons appear little larger, but not as huge as with the large icon setting.