Why is this happening?

Hi Jose - I guess the basic display problem is, Rhino does not draw the backfaces of meshes that are closed. A non-manifold mesh can be closed but the inside/outside is jumbled by the non-manifolds. If you extract a face from this mesh, and Unweld it, it cleans up the display.


Thanks Pascal, now I understand where the issue resides. The thing is, that for a simple file, extracting and unwelding might be a feasible solution, but for more complex files this is really a nightmare, i.e. files with lots of blocks, having to enter one by one… Also, am I right thinking that this will destroy any prior uv mapping done previously in SketchUp? So imagine having to go back to sketchUp to make a change and having to redo all the work…

The easy way out might be just to allow drawing all meshes on both sides. In some form: per object, per display mode, globally… I don’t know. I expect that is what other apps are doing.

RH-57907 Allow drawing both sides of non-manifold meshes



When this test model is imported into V5 it shows the problem; - the objects are 21 blocks. If you explode the file, then you have 21 mesh objects, then run unify normals, which fixes the issue here.

If the file is loaded into V6 it just imports fine…


when I import my file into V6 i still see issue?
is it my import settings?

i guess ‘trimmed planes’ is the way forward for me…

1 Like

Interesting, I will have to test that option, thanks.

only issue with ‘trimmed planes’, file in rhino much larger … but it does work…

Yes, that’s one of the issues, also I imaging that for curved surfaces, even if these are triangular planar faces in SketchUp, this solution would destroy the smoothness angle and will turn the surface into a faceted one. Also, have you tried if using trimmed planes messes up with UV mapping from SketchUp?

fwiw- v7 opens this just fine, no issues.

good - progress…