Display modes not working properly


My 3D model is not working properly, the volumes look all mixed up when I zoom in, in all display modes.

I uninstalled and installed again Rhino, the problem is still there!

Please help me!

The most common issue is that your model is a long, long way from the origin.

1 Like

Hi Jim, thank you for your ansewr!

My model is not far away from the origin though :sob:

Can you provide a file with an example of your geometry? It could be a subset of the geometry in your images. You can click on the vertical arrow above where you type a post, or drag the file to the window where you type a post.

How far is the model from the World origin (not a local CPlane origin). Your model appears to be buildings, etc. Frequently such models are created using geo coordinates.

What are the setting in DocumentProperties > Units > Units and tolerances?

1 Like

Hi David!
Thank you for your help! :pray:
How do I know where is my World origin??
I’m attaching a screenshot of my DocumentProperties! And my 3d model!
Buildings.3dm (17.4 MB)

Hello - you are some distance from the World origin (Distance w0 and then click on a point in your model) but not really a huge distance. Here it shades correctly in place. Can you please run the
command in Rhino and post the results?


1 Like

Lots of coincident surfaces in several parts of the model when cause patching colors and flashing when I zoom in and move the viewpoint on my system. Moving the objects to close to the origin did not eliminate.

1 Like

Hello Pascal and thank you for your help!
Here are the results:

Rhino 6 SR22 2020-1-28 (Rhino 6, 6.22.20028.13281, Git hash:master @ 379871ece695dc096e83826f08b429db8ca2e7f5)
License type: Evaluation, build 2020-01-28
License details: Stand-Alone
Expires on: 2020-05-20

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: LAPTOP-49AJ3COE

Hybrid graphics system.
Primary display: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 9-28-2018 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 1050 (NVidia) Memory: 4GB, Driver date: 12-11-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 417.35

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-11-2018
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - I would check the NVidia website for an update - at least to eliminate the driver as a possible contributing factor.

Open the Notifications panel (Panel menu) and look for a notification about drivers - double-click on that and follow along to get to a newer driver - download and install that and see how things work.


1 Like

I installed the updates… nothing changed :frowning:

Hi - Is it any better when you run ClearAllMeshes and then put the view in a shaded mode again?
Also, as @davidcockey said, there are coincident surfaces and those will always flash…


Hi Wim! Thank you for your help!

I know the about the coincident surfaces but this doesn’t happen only there, it happens everywhere! I re-modeled my volumes and it still has the same problem… which is annoying because then it also doesn’t snap properly!

I just tried the ClearAllMeshes again but still no luck… it is very weird and annoying :sweat:

@wim - do you see any of the problems, apart from coincident surfaces, that the OP shows? Here it looks correct.

@ivarvaroussi - as a test, try selecting everything in your file and Copy/paste to a new empty file using the same units. Is that any different?


1 Like

@pascal - it’s a bit view-dependent (angle and zoom) but this is what I see:

(I don’t know why Discourse insists on cropping animated GIFs to 50x32 lately… - zipped in original size: 2020-02-21 DisplayIssue.zip (4.1 MB) )

It’s better in a shaded mode with less wires:

In Rendered mode you can see something fishy with the meshes:

Here’s one simple part in that file (left-most in gray) and, in red to the right of it, a new object that was made with Box > 3Pt over the existing object. Then, to the right, are the extracted render meshes of both. Somehow the original objects have some weird meshing.

ClearAllMeshes, copy, and paste into a new Rh7 document:

Any ideas?

1 Like

Hi guys!

I just pasted my model into a new document like you said, and cleared all meshes, and so far it looks like the problem has been solved!!!

Thank you so much for your help!!! :pray: :pray: :pray: