Why is seamless texture mapping so difficult on my Rhino models?

Here’s a sample scene containing a shirt that is hugging a character model I created. The shirt is originally a polysurface. I’ve also run QuadRemesh on it and created a mesh version with nice, clean quads.

However, for some reason, neither of them allow me to cleanly tile a texture on them in any other program. Here’s what I’ve tried:

  • Exporting the polysurface as an OBJ and texturing it in Cinema 4D.
  • Exporting the mesh as an OBJ and texturing it in C4D.
  • Exporting both to Keynote using the Keynote plugin.

No matter what, when I try to tile a material/texture on it, I get these broken/fractured edges all over.

Here’s an example of trying to apply a checkerboard texture in Keynote:

In Cinema 4D I’ve also tried every kind of projection mode, including UV and cubic.

I just don’t understand. The quad mesh version in particular looks really clean to me, and the topology in other programs like C4D look nice too.

So what’s the issue here and how can I resolve this? It’s a big disappointment because I’m becoming very adept at character modeling in Rhino, but it’s nearly impossible to use in any other rendering software outside of using flat colors on the shapes… and I’m really hoping to avoid UV unwrapping models and making that a part of my workflow, since I’m really only ever trying to tile a basic texture once and a while.

shirts.3dm (2.6 MB)

Hello - mapping via Cylindrical or any of the other mapping types (other than Surface) seems to lok as expected to me so far -