Why is paste so slow?

In Rhino 6, pasting geometry is a little slow, but in the WIP it is super slow. In Rhino 5, it’s instant. What’s going on?

In the WIP, copy w/InPlace is instant, and so is dragging a copy using the gumball holding ALT, but using the windows clipboard is where it’s super-slow. It takes literally 4 seconds to paste a cube in Rhino 7.

I have ‘allow copy and paste to version 6’ turned off (it’s even a little slower with it on.)

1 Like

Do you have any large textures or picture objects in your file?

No, this is just with freshly-opened rhino and the object in this example is a simple cube.

Hmm, I guess we need to look at plug-ins or other possible sources of the problem then… Can you run SystemInfo in Rhino and copy/paste the results here?

I’ve tracked it down to OpenGL, so I’m looking into how to fix it.

Well, I updated drivers, etc, but no luck. If I change Display Pipeline Assignment to Windows, then it works perfectly, but when I use Open GL, no luck.

Rhino 7 SR0 2020-9-15 (Rhino WIP, 7.0.20259.15365, Git hash:master @ 7b653f7913cee10b2bd173435b93e0202bd2ae71)
License type: Commercial, build 2020-09-15
License details: Cloud Zoo
Expires on: 2020-10-30

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro K3100M (NVidia) Memory: 4GB, Driver date: 5-29-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 426.78

Secondary graphics devices.
Intel® HD Graphics 4600 (Intel) Memory: 1GB, Driver date: 9-29-2016 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-29-2020
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\SimLab\Plugins\SimLab 3D PDF From Rhino 6\plugins\SimLabPDFExporter.rhp “SimLab PDF Exporter”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” 7.0.20259.15365
C:\Program Files\Rhino WIP\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino WIP\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino WIP\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino WIP\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.0.20259.15365
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.20259.15365
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.20259.15365
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.20259.15365
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”

I would update the Intel driver as well, or, as others have suggested, disable the onboard Intel graphics card completely. If that improves things, that’s it…

I disabled the Intel graphics, but no improvement.

Ouch - OK - someone else will have to chime in here… @pascal ?

Hi Peter - I also see a noticeable lag on Paste in V7 - one second or so, here -, a very slight one in V6… and none in V5.
My wild ass guess of the moment is that the extra in V7 may be related to the extra copy/paste capabilities added to V7 - you can paste to Illustrator for example - @stevebaer - is that possible, that the new stuff is taking time?


Very doubtful, but anything is possible. We won’t really know the cause until a developer can repeat the lag in a debug build of Rhino

Yeah, plus, I also see it is instant in V7 if I set the display to use Windows.

RH-60569 Paste lags


Thanks, I’m so glad you can see the problem, too.

I do experience it as well, even the most simple elements like single curve or face. Latest WiP build.

Yep noticed this here too, glad someone wrote in about it and McNeel might work on it. It doesn’t matter if it’s a lot of information or just one line still takes a while.

Same problem here: pasting takes a lot of time in v7 Beta (it was happening to me also in v7 WIP).

And it happens on all the THREE different PCs I have in my studio: a desktop workstation DELL T7600, a Portable Workstation DELL M3800 and a Microsoft Surface Pro 7. On all of them pasting takes years, also starting from a clean file, modeling a single cube and trying to copy/paste it.

In my case, on the T7600 and the Surface, setting Display Pipeline to Windows instead of OpenGL, solves the problem. (but of course I wouldn’t keep this setting). If I try to do the same on the DELL M3800, viewports are not working anymore: modeling works “blind” as whatever you do nothing changes in the viewport. The viwport remain “frozen” to the visualization that was there before switching display pipeline to “Windows”. So on that machine not even windows display pipeline works properly.

Hope that a solution will be found.


Was there a fix to this, even if manually modifying settings. Starting to become a bit painful.


Hi James the current service release candidate should have the fix - change Options > Updates and Statistics page > Udate frequency to ‘Service release candidate’ and click ‘Check now’
Any luck?


1 Like

Excellent, seems to work.

Appreciate the very quick response.

Thanks Pascal.