Why file so big if I save with texture?

i have a free model of human with map. model is 4 mb and map is 6 mb.
if I save with texture, why is file size 60mb and not 10mb?

anyone??

How big is it if you save without the textures?

4mb - so very small

Well, I’m going to hazard a guess here - You have a mesh - which is basically just a collection of points and a list of which points make which mesh face - plus the image itself stored in the file. Each one of those has a memory size and you could basically add them together to get the total.

But, you have also applied the image to the mesh as a texture. That means each mesh face gets a color (maybe the mesh vertices as well) and that will add a huge amount of information (size) to the mesh object. So I expect (suspect?) that it’s the texture being applied to the mesh which is contributing to the file size.

You could maybe run Audit3DM on the file and see what it tells you about the objects in the object table.

This is just a theory of course…

hello and thank you, for me this seems like a very simple question… i can understand if the file is 10mb.

here is the Audit3DM results:

Testing 3dm Archive: E:\3d models\3d People\Humano_FreeSample\2 x people business sitting.3dm
Start Section: 382 bytes (offset 0 to 382)
Offset: 0
3dm archive version: 50
Interface Name: Rhinoceros 5.0 - Worldwide Commercial, build 2017-05-05 - (compiled May 6 2017)
SDK Version: 201103035.201705055
OpenNURBS Version: 201705055
3dm Version: 5
Operating System: Windows Platform 2 (6.2) build 9200 sp 0.0, suite 768, product type 1
3DM I/O processor: OpenNURBS toolkit version 201705055 (compiled on May 6 2017)

Properties Section: 38030 bytes (offset 382 to 38412)
3dm archive openNURBS version: 201705055
Application Information:
Name: “Rhinoceros 5.0”
URL: “http://www.rhino3d.com
Details: “Worldwide Commercial, build 2017-05-05”
Revision History:
Create Time: Wednesday April 29 12:16:45 2020 UCT
Last Edit Time: Friday May 08 08:07:35 2020 UCT
Revision Count: 5
Created By: “Richard Follett”
Last Edit By: “Richard Follett”
Settings Section: 13196 bytes (offset 38412 to 51608)
Plug-ins:
Name: 3Dconnexion 3D Mouse
Version: 1.1.17126.139795
Id: DCA0DB8D-844C-48d6-BA97-F5595FE6AFDB
File: C:\Program Files\Rhinoceros 5 (64-bit)\Plug-ins\3dxrhino.rhp
SDK Version: C++ 201103035.201705055
Name: KeyShot7RhinoPlugin
Version: 1.6.0.0
Id: 486807A0-D332-4669-8086-E0497D91ACD5
File: C:\Users\Richard Follett\AppData\Roaming\McNeel\Rhinoceros\5.0\Plug-ins\KeyShot7RhinoPlugin (486807a0-d332-4669-8086-e0497d91acd5)\1.6.0.0\KeyShot7RhinoPlugin\Rhino 5.0\KeyShot7RhinoPlugin.rhp
SDK Version: .NET 201103035.201705055
Name: KeyShot9RhinoPlugin
Version: 1.0.0.0
Id: ECFE8D1F-876A-460f-AA5E-3DD816936811
File: C:\Users\Richard Follett\AppData\Roaming\McNeel\Rhinoceros\5.0\Plug-ins\KeyShot9RhinoPlugin (ecfe8d1f-876a-460f-aa5e-3dd816936811)\1.0.0.0\KeyShot9RhinoPlugin\Rhino 5.0\KeyShot9RhinoPlugin.rhp
SDK Version: .NET 201103035.201705055
Name: Renderer Development Kit
Version: May 6 2017 00:39:51
Id: 16592D58-4A2F-401d-BF5E-3B87741C1B1B
File: C:\Program Files\Rhinoceros 5 (64-bit)\Plug-ins\rdk.rhp
SDK Version: C++ 201103035.201705055
Name: Rhino Render
Version: 1.50, May 6 2017, 01:16:15
Id: 5DC0192D-73DC-44f5-9141-8E72542E792D
File: C:\Program Files\Rhinoceros 5 (64-bit)\Plug-ins\RhinoRender.rhp
SDK Version: C++ 201103035.201705055
Name: Rhino Toolbars and Menus
Version: 5.0.6335.572
Id: DC297053-96C0-4883-A688-8326B4E024A8
File: C:\Program Files\Rhinoceros 5 (64-bit)\Plug-ins\Toolbars\Toolbars.rhp
SDK Version: .NET 201103035.201705055
Name: SimLabSoft PDF Export Plug-in
Version: Feb 15 2015 15:08:13
Id: C30D95F5-DBDC-4331-9006-8009498528FE
File: C:\Program Files\SimLab\Plugins\SimLab 3D PDF From Rhino\SimLabPDFx64.rhp
SDK Version: C++ 201103035.201108315
Name: TSplinesUi
Version: 1.0.0.0
Id: FFF606B3-FC09-4518-BA4A-EC92E59FDF9B
File: C:\Program Files\Autodesk\T-Splines for Rhino\TSplinesUi.rhp
SDK Version: .NET 201103035.201705055
Name: V-Ray for Rhino
Version: 4.10.01 ( Sep 24 2019 )
Id: E8CFE179-B60C-411a-8416-62A893334519
File: C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V5\VRayForRhino.rhp
SDK Version: C++ 201103035.201209275
Bitmap Table:
0 bitmaps, 24 bytes (offset 51608 to 51632)
Texture Mapping Table:
0 texture mappings, 24 bytes (offset 51632 to 51656)
Material Table:
material[0]: Basic Material 001
material[1]: Basic Material 003
2 materials with 2 plug-in data items, 2500 bytes (offset 51656 to 54156)
Linetype Table:
0 linetypes, 24 bytes (offset 54156 to 54180)
Layer Table:
layer[0]: Humano 30K
layer[1]: Humano 100K
layer[2]: Humano_30K
layer[3]: default
4 layers, 1036 bytes (offset 54180 to 55216)
Group Table:
0 groups, 24 bytes (offset 55216 to 55240)
Font Table:
font[0]: Default
1 fonts, 297 bytes (offset 55240 to 55537)
DimStyle Table:
dimstyle[0]: Default
1 dimstyles, 318 bytes (offset 55537 to 55855)
Light Table:
0 lights, 24 bytes (offset 55855 to 55879)
HatchPattern Table:
hatchpattern[0]: Solid
1 hatchpatterns, 157 bytes (offset 55879 to 56036)
InstanceDefinition Table:
0 instance definitions, 24 bytes (offset 56036 to 56060)
Object Table:
object[0]: Humano_02Casual_18_30K
object[1]: Humano_01Business_01_30K_01
2 objects with 6 plug-in data items, 4560114 bytes (offset 56060 to 4616174)
History Record Table:
0 history records, 24 bytes (offset 4616174 to 4616198)
Model User Data Table:
user table[0]: (57325007 bytes)
Plug-in name: Renderer Development Kit
Plug-in id: 16592D58-4A2F-401d-BF5E-3B87741C1B1B
user table[1]: (497 bytes)
Plug-in name: Rhino Render
Plug-in id: 5DC0192D-73DC-44f5-9141-8E72542E792D
user table[2]: (100913 bytes)
Plug-in name: V-Ray for Rhino
Plug-in id: E8CFE179-B60C-411a-8416-62A893334519
3 user tables, 57426720 bytes (offset 4616198 to 62042918)
Archive size = 62042938 bytes (end mark size = 62042938)

This looks like V-Ray - 57Mb of data being used by the plug-in… I guess it’s the texture mapping info, but no idea really.

image

thank you

deactivated the Vray plug to see if that made any difference… no, just the same

so I tried this in version 6… In 6 there is a new flag when saving ‘save plugin data’ seems which I switch that OFF then the file size is back to very small… so must be some data in there that is linked to a plugin…

Yes, and that plug-in looks to be V-Ray. Deactivating the plug-in does not purge the data it has stored in the files, only saving without the plug-in data does.

and no option to do that in V5?? or have i missed a flag

-SaveAs (dash version) has the option on the command line in V5. It is indeed missing from the dialog version.

wow - worked!

never new about the Dash version of commands, does this apply to all commands in 5?

The dash version of a command bypasses a dialog box - if there is one - and all the options are shown as command line links. This is designed to make all commands macro-able. If there is no dialog for a command, the dash version runs like the regular command. However there are a few commands where running the dash version exposes some additional command line options.

Dash versions have been around since V2 or earlier.

https://docs.mcneel.com/rhino/6/help/en-us/index.htm#information/rhino_scripting.htm%3FTocPath%3DScripting%20and%20programming|_____1

1 Like

thank you for your help and time, much apprciated.

Hello :slight_smile: