Why do I need to validate my license every time I open Rhino

I’ve put my Win license # in several time with success, why do I need to do this even after my computer sleeps, then I continue to work again.

Can you please give us more information so we can understand the problem. For example, what version of Rhino for Mac are you using? Why are you entering a Windows license # in Rhino for Mac? The more information we have, the more we can help.

@mbdza Michael, I removed your post because your license keys were visible in the images.


Thanks, I thought it was a personal email address.

Hi Michael,

There are a couple things going on here. First, you installed an evaluation license of Rhino for Mac (the one ending in 9Q6X). That license needed to be validated, and I see you validated it several times. I’m not sure why that happened as there aren’t any error logs for that license.

Then you purchased Rhino for Mac and entered your commercial license (the one ending in RQ85). This license has been validated only one time.

Are you now able to start Rhino for Mac without being asked to validate?

Not the first time I launch…Using RQ85 It shows me my “getting license page with file selection”…
When I select and try to open a file, It brings me to the (BUY, or ZOO, or Enter a license, Continue) … entering a license brings me all the way to asking for my Rhino 5 Win license…
Today I didn’t comply… closed Rhino… relaunch… no problem, Rhino starts…
I just did that 10 Minutes ago.
closed all down…
I just tried again, I got to the first “Welcome to Rhino Validation” Page
I tried to quit… Also use command Q, Nothing…needs my email address to continue… Instead I go to file/close to try and quit.
That launches Rhino no problem

The 5.0.1 “You’re running an eval and have XX number of days left” is being misunderstood.
I had another person that was confused by this too and thought it was a prompt for Validation.

Perhaps a different reminder is needed.

@jb, no, I’ve got screen shots that show this is a different problem from what you describe. Michael clearly has a commercial license installed and is being nagged to validate repeatedly.


I’ll send you a private message to continue this discussion.