What settings need to be changed for Apple Metal?

Am I missing a setting that needs to be changed? I’m trying to get set back up using Rhino again, haven’t used it in a few years. I bought an Apple M1 Max MBP and downloaded the Rhino 8 WIP so I could see how Metal was running, but every time I open a file and try to change my display style Rhino crashes immediately.

Move to the Serengeti - Mac category.

Run TestMetal command to toggle

I thought the Metal display code is turned on by default in the Mac WIP builds for a while now.
Am I remembering incorrectly?

TestMetal is the only thing I’ve changed. It runs slow before I run the command, but after I run the command is when it crashes after trying to change display style. I’m curious if there are other settings that need to be changed that I’m missing or would help.

No, by default its OpenGL

Can you post your SystemInfo and provide steps to reproduce the crash? (is the command toggling metal or openGL before switching display style). I’m updating my WIP and will do some testing shortly.

I do not see that you have sent in any crash reports.
Since it sounds like this can be repeated, why not?

I did submit the first one, it was submitted under the name Michael Turner and a different email so any response would be seen immediately

Rhino 8 SR0 2022-9-6 (Rhino WIP, 8.0.22249.12306, Git hash:master @ 40d87b6e847c6c827f8fc10401ce04883ecdfa80)
License type: Commercial, build 2022-09-06
License details: Cloud Zoo
Expires on: 2022-10-21

Apple macOS Version 12.5.1 (Build 21G83) (Physical RAM: 64Gb)
Mac Model Identifier: MacBookPro18,2
Language: en-US (MacOS default)

Apple M1 Max (OpenGL ver:4.1 Metal - 76.3)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Apple
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 48 GB
Graphics: Apple M1 Max
Displays: Unknown (255dpi 2x)

Metal GPU Family Apple 7
Metal GPU Family Common 3
Metal GPU Family Mac 2
Graphics processors
Apple M1 Max
Color LCD (1728 x 1117 @ 120.00Hz)

USB devices

Bluetooth devices

Third party kernel extensions

Third party plugins

Rhino plugins that do not ship with Rhino
/Users/michaelturner/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/FJ_FreeJewelsToolbar.rhp “FJ_FreeJewelsToolbar”

Rhino plugins that ship with Rhino
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 8.0.22249.12306
/Applications/RhinoWIP.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 8.0.22249.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoRoslyn.rhp “RhinoRoslyn” 8.0.22249.12306
/Applications/RhinoWIP.app/Contents/PlugIns/Constraints.rhp “Constraints” 8.0.22249.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/ConstraintsUI.rhp “Constraints UI” 8.0.22249.12306
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 8.0.22249.12306
/Applications/RhinoWIP.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 8.0.22249.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 8.0.22249.12306
/Applications/RhinoWIP.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 8.0.22249.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCPython.rhp “RhinoCPython” 8.0.22249.12306
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 8.0.22249.12306
/Applications/RhinoWIP.app/Contents/PlugIns/Displacement.rhp “Displacement” 8.0.22249.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoRenderCycles.rhp “Rhino Render” 8.0.22249.12306
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 8.0.22249.12306
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCodePlugin.rhp “RhinoCodePlugin” 8.0.22249.12306

I looked up the email mail address you are using here in the forum.
Unless you notify us specifically, the crash reports are processed anonymously.
If it crashes again, please send in a report with your email address.
Then send a message to tech@mcneel.com using that same email address and let us know.
Then a developer can find the report and maybe learn should specific.


Repeated the crash and submitted a new report and set out the email, thank you

It is toggling Metal before switching display style.

Thanks, I do see the crash reports but haven’t been able to replicate on my M1 on the same version of WIP.

Can you disable this plugin, restart Rhino and try again?

Rhino plugins that do not ship with Rhino
/Users/michaelturner/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/FJ_FreeJewelsToolbar.rhp “FJ_FreeJewelsToolbar”


That hasn’t fixed it either. I just tried it and submitted a new report.

Thanks for trying. The only other difference is the MacOS, i’m still on 12.4, will get that updated and give it another go.

Thank you for your help! Would the type of file have anything to do with it? I’ve been importing STL’s since I’m converting over from another program.

I was under the assumption this was happening in a blank file. Can you provide us the file to look at? Either upload here or privately. Thanks

No, it all works fine with an empty workspace. This is the specific file I’ve been trying to import.
Rook.stl (10.1 MB)

does it die on all files or just this one?