After update latest WIP Crashing

Can I please get a link to the previous public build, I just updated to: 8.0.22088.20306, 2022-03-29 and it crash upon opening of document . my doc is in V8 so I can’t continue in v7. [crash report has been sent]

thanks a lot

Open your file in a WiP Safe mode and save it as V7.
Use it as a temp solution.
Mine is crashing constantly for about 3 months now. I don’t know how to fix it. McNeel is quiet in this case.

1 Like

This is a Mac crash that was introduced this week. @Akash can you open Rhino to a point where you can run a command? If so, run TestMetal to turn off metal.

If you can’t run Rhino at all, open terminal and run
defaults delete com.mcneel.rhinoceros.8.plist

Then try to restart Rhino. This should put Rhino back into using OpenGL by default.

Please let me know if this fixes the crash you are seeing. We made a pretty big change to metal display this week and are trying to pin down the crash. Unfortunately it isn’t as consistently crashing on my Mac as yours.

2 posts were merged into an existing topic: Struggling to open anything in recent WiP

Hi @stevebaer
I can’t open the WIP at all,
Before deleting the plist… I need to backup my Pref. [Export Preference ]. as I’m not sure if I have the latest one backup!
is there a way to back it up from Terminal?
Other wise, If you don’t mind, please send me a link to the previous public build, I’ll do a Pref backup with it [and turn off Metal on the way] and then I’ll try to run the latest public with TestMetal off

thanks a lot

Yes. You can copy it to your Desktop like this:

  1. Quit Rhino completely (make sure no Rhinos are running.)
  2. Wait about 10 seconds (this is because macOS can write to Preferences files for apps even after they are closed…we want macOS to do this).
  3. In Terminal: cp ~/Library/Preferences/com.mcneel.rhinoceros.8.plist ~/Desktop.

(Alternatively, you can copy the file using Finder - the regular way - but this requires knowing how to get to that folder).

Hope that helps until we get this problem fixed.

There is an alternative way to disable Metal without deleting your preferences entirely

  1. Quit Rhino completely.
  2. Launch the (/Applications/Utilities/
  3. At the command prompt, type:
    defaults write com.mcneel.rhinoceros.8 User.Options.Advanced.TestMetal -boolean false
    and press return.
  4. Quit Terminal.
  5. Launch the RhinoWIP. Rhino should now use the Legacy OpenGL display.

Thanks a lot @dan that one worked. I’m able to open files now in the Legacy OpenGL. The OpenGL creates weird display artifacts
[viewport should be dark grey , and that sphere is not doing too well as well]

  • by the way, I don’t think the first Terminal option you suggested worked… as I could not find the Plist on the Desktop …?

one other thing [perhaps not related to Rhino [?] in Terminal it says:
{The default interactive shell is now zsh.
To update your account to use zsh, please run chsh -s /bin/zsh.
For more details, please visit}
is this in anyway related?

thanks allot

No, it is not related at all.

Hi Akash -

The plan is to get Metal to work for Rhino 8 on Mac. There is no work planned for OpenGL on that platform and version.

thanks a lot

update: I restarted the WIP and opened another file, and rhino works correctly in OpenGL.
Switching back to Metal Crash The WIP.


We do want to make things at least look somewhat correct on OpenGL. Can you share this model so I can try and repeat what you are seeing? What model Mac and MacOS are you on?

baseballAllOver.3dm (180.9 KB)

thanks a lot

Are you able to update this Mac to Monterey?

Perhaps … I sometime see a desktop banner suggesting Monterey goodies.
there’s an Update [I see now] for BigSur … I’ll try that first.
If no change, I’ll try Monterey.

Hi Steve, I updated to 11.6.5.
Unfortunately Monterey is only supported down to the 2015 models.
the big sur update didn’t help with the Metal crash, nor with the OpenGL Art effects.

A few month ago, there was a period in which the WIP was crashing in a similar way, It eventually self healed, right until this latest Public.
Please Kindly send me a link to the previous Public build.

I’ll keep trying the weekly WIPs and will post here once they [hopefully] readmit this old machine.

thanks a lot

Disabling GPU tessellation Fixed the Open GL Artefact
[Metal still crash]

thanks a lot

There was a note in today’s WIP 8.0.22102.12306. That Metal crashing was fixed… So just to update that it is still crashing here.

thanks a lot

Happy to note that today’s WIP [8.0.22123.12306] seems to have fixed the Metal crashing issue I’ve been having for the last month.
Still On Big Sur, and the same old 2013 MBP.

thanks a lot

1 Like

That’s great news and thanks for letting us know. We’ve been working on a metal based update to our iOS viewer app and found a crash on some older phones due to some missing metal functionality that we assumed existed. This is probably the same issue with older macbook pros where some functionality doesn’t exist on older hardware and we need to account for this.