WELD on polysurfaces

I was studying about the Weld command, and I found something that I didn´t understand.

If the mesh is a solid, there are not naked edges (or vertex); however, if it´s a poysurface even after applying the Weld command, it keeps showing naked edges.

The problem is that it seems incorrect, cause they are welded in fatc.

It is hard to judge from pictures, but your mesh doesn’t look like a solid/manifold object (doesn’t look like it encloses a volume).

Hi Joddys - Weld, on a mesh does not close it up, it welds mesh vertices that are already in the same location. Open edges will remain open. If you think the edges should be closed, use AlignMeshVertices and/or MatchMeshEdge to close up nearly closed edges.


1 Like


Inspectin the mesh later, I´ve noticed that some vertex didn´t weld correctly after Weld command.

Why? There were no naked edges on the surface.

PS: In the image above (previous post), you can se some vertex highlighted in the middle of the piece, and they are not on the edges.

Hi Jodys - Weld has an angle setting- if the angle between adjacent faces is larger than the angle setting, Weld will ignore them - use 180 degrees to completely weld all weldable vertices.

Does that help?


I did exactly as you said, as well as is documented in the Help.

I´ve tried also with different mesh settings (meddium/high density)

Hi Joddys- better post the mesh, or send it to me via private message.