Result of "Mesh"-Command from Solid has Naked Edges

We have a solid that we want to create a mesh from. To achieve this i use the mesh command choose “Smooth&Slower”. When running the Mesh command the mesh is created, but when using the ShowEdges or the Check command we can see that there are some naked-edges.

Does anyone have any idea how to avoid that? I’ve read in another post, that this can happen if you have Jagged seams selected in your mesh settings. But since i’ve set it to “Smooth&Slower” that should not be an issue.

Thanks for any help


I would suggest you use the detailed controls in order to set the values according to your desires.

Sometimes the meshing creates some errors such as exposing manifold edges, sometimes even duplicate faces and so on as you have already mentioned.

If you have a fairly complex but correctly generated geometry, all of the issues you mentioned are usually very easy to eliminate with the check mesh command. If you check the mesh, click next, next again you get to a window with a slider determining small gaps sizes and so on. you can set the domain according to your modelling units and step by step increase it until all naked edges are gone, gaps are filled, etc.

Usually if nothing before this helps, this is the place where you finally get a clean mesh. if you can share your file i could give it a try.


Hi Manni - can you please post or send me an example object ? I’d like to try it here.



Here’s an example, @pascal.

It doesn’t seem to matter what the mesh settings are - the extracted render mesh always has an open edge. I also tried this in the WIP with the same result.
Rendermesh from closed polysrf is open - small.3dm (212.1 KB)

This is a known problem - it would be nice if it could be fixed in Rhino 5 too.

Thanks…Hmmm - the Mesh command gets me a closed mesh, ExtractRenderMesh at the same settings, does not… I’ll have a coffee and check the settings. I still would like to see @manni 's example if possible, I’m not sure it is always the same problem.


The thread referred to in the first issue that menno linked to (the second one is invisible to the public) states that the mesh command includes a healer function.

Apparently the extraction of the render mesh doesn’t go through this one.

Thanks for all the input. i’ve sent my file to pascal and will report back if anything comes up

I responded to the private message, but just to keep others in the loop, I believe the problem in Manni’s case was caused by using CreateSolid to ‘join’ surfaces that are edge-to-edge instead of Join. I got a good mesh if I Joined the surfaces.


1 Like

Hi @pascal

I run into naked edges on extracted render meshes quite often (V5). Is this something I should report? I always thought, that the render meshes were meant to be “lower” quality meshes than the actual mesh command, and never botherede to report them…

TIA, Jakob