Problems displaying all edges when zoomed in

I set it to show only the naked edges as in the screenshot in order to see the clean rendering view and the side edges of the plane surface only. However, unlike the front view + light view, if you zoom in more than a certain level like the perspective view, all the edges are displayed

Hello - are these objects polysurfaces? That is, not block instances? I cannot reproduce this so far but if you have a file that shows the problem, please post or send to, with a link back to this topic in your comments.


Yes polysurface. If all files are enlarged a lot in the current setting, it occurs at 100%.

In the attached image, the edges of the front and right views are not visible. You can see what you see in the enlarged perspective view.

Make the settings the same as me and then zoom in on the polysurface. When you zoom in to some extent, the edges start to appear.

Hello - thanks, I do not see that yet, still, but I do see that just opening the Options page you show sets the surface edges on in the Display panel. That seems like a bug in itself.
RH-62620 Options: opening page changes the display setting

@flawless8862 - I see the zoom problem now as well - thanks. I think it depends on having some geometry behind the camera - still testing.

RH-62621 Display: Zoom level shows edges


Symptoms were recorded and attached by repeating zooming in/out at the marked edges.
Again, I’ve opened all the dozens of data and all of them happen the same.
It is not an object problem.

Both versions of the Rhino 6 and Rhino 7 have the same problem. I hope you fix everything. Thank you.