Weird selection problem (meshes in Wireframe mode)

Hello, recently my Rhino 7 started a weird behavior where Mesh objects can be selected in Wireframe mode not only by clicking on wires, but anywhere on mesh face (something that normally works in Shaded/Rendered modes only). Sufraces act as expected btw.

Running Rhino 7 latest SR. Rhino 8 WIP works as expected.

Any suggestions what may be causing this?


SysInfo.txt (2.8 KB)

thanks,

–jarek

1 Like

Hi Jarek,

I’m not seeing that here (7.28.23041.13001, 2023-02-10)… Hmm.

does the problem still exists after a complete restart ?
(Windows + Rhino) ?

Thanks Mitch and Tom,
The problem still exists, after Rhino restart and system restart. So weird, I did not realize how annoying it would be until it started happening.

Any other ideas what can be causing this?

Best,

Jarek

Hi Jarek -

Just to be sure, have you tried disabling the non-default plug-ins?
Apart from that, I’d create a new scheme and launch Rhino with that to check if the behavior persists across that.
-wim

Hi Wim,

Disabling the plugins did nothing.
Resetting the Wireframe display mode to default settings also nothing.

New scheme - all works OK and expected…
Now - how to I apply this finding to fix my current scheme??

Thanks!

–jarek

Hi Jarek -

Good question : )
I suppose the first step is to identify the exact file that holds the difference.
Most likely, that’s the settings-Scheme__Default.xml file in
%AppData%\McNeel\Rhinoceros\7.0\settings.
From what I recall, however, the structure of that file is not predictable and not necessarily the same when comparing two versions of it. Normally, I would throw something like that into Excel and have that highlight the differences between the two but it’s not as simple as comparing two cells in the same row in two columns.
It’s text, though, so you can read your way through them.
If all else fails, send them over!
-wim

Thanks Wim, I tried to look to my best abitily but don’t see anything that may be a good hint of why this is happening. Tried switching different obscure Rhino options too, like snaptooccluded, some selection and sub-selection related stuff, scanned through advanced options… nothing : / So weird.
Here are the scheme setting files just in case you wanted to take a look:
settings-Scheme__Default.xml (189.6 KB)
settings-Scheme__MyNewScheme.xml (6.3 KB)

@wim, it stared working again OK, honestly not sure what I did, I was trying a lot of things, including updating the video driver, defauling wireframe more etc nothing seemed to work, then after restart its back to normal. Thanks for your time trying to figure this out!

best,

Jarek