Bug: Shade-highlight Selected does not respect 'Mesh Wire Display' toggle

Shade selected always shows the mesh wires, even when turned off in display settings. This is not the expected behaviour - compared to the windows version and all older versions.

Here on Windows in both v7 and WIP, mesh wires are shown when a mesh is selected and AFAIK mesh wires have always been shown when selected, independent from enabling or disabling shade selected.

nope… not since at least 10 years

Hi Atair -
This is the first time I’ve run the ShadeSelected command, so bear with me…
You put your viewport in Shaded mode and run ShadeSelected. Then you turn off the display of wires on mesh objects in the Shaded mode.

This makes all mesh objects in that viewport invisible. I suppose that’s fine because you can still select them in other viewports.

When I then, in the WIP on macOS, check the Shade-highlight selected meshes setting in Options -> Display Modes -> Shaded -> Objects, mesh objects are highlighted but don’t show wires when selected.
Are you running Rhino with the Metal display pipeline enabled?

Hi Wim,
no - its not about the shade selected command, but the display mode property - here some images to illustrate:
This does not work as expected in macOS wip
edit: realised i called it wrong - its the shade-highlight selected, not shade selected…

Hi -

Good to have that one part clarified, but those pictures are not helping me much in understanding what’s wrong. Clearly, those pictures are from the Windows version. On my Mac, that appears to behave exactly like in those pictures.


here the mac screenshot from the current wip build:
also new is this boundary bug - it shows when overriding the edge colors of the mesh. I made a thread about this here: Bug: Mesh Wires Display always shows Naked Edges when Color is overridden
If you say yours looks like it should, could it be the overrides trigger the mesh display? havent tried that yet…

From that screenshot:

… which answers my Metal question.
We won’t be fixing anything that’s wrong when using the legacy OpenGL display pipeline in Rhino 8 on macOS. Please run TestMetal and see if that changes things.

its the same unfortunately:

ps: as i have your attention - do you see the problem with the sphere? This default environment that is here since at least 15 years is a really bad decision - and a big turn-off for any potential new user. Because it suggests that whoever is in charge has little to no regard for visual clarity / language when it comes to 3d…

Hi -

Please run the Rhino SystemInfo command and copy-paste the result here.

i do not think there is need for that… switch any of the Edge Settings to Single Color and it will start shading the mesh edges no matter the display setting:

I see that, but I see that across all versions I’ve tried (6/7/8), while you mentioned in the start of this thread:

So the bug you report is actually only your last image of the settings, is that a correct conclusion?

sorry I am not sure what you mean?
On Windows the setting on the last image does NOT override any mesh wire display. All wires are off, when the viewport panel has mesh wires set to off.
On macOS - the settings in the last image override the viewport panel settings.

There is no way to hide mesh wires when selecting an object (that is the issue!)

It is not fun working with superheavy meshes - two images to illustrate:

pls send me the _SystemInfo on the computer that does this right, because I get the same thing on Windows, I wanted to verify if this is the correct bug I need to log

you are right! - it is also in v7/8 windows… mixed it up with surface edge override

Rhino 8 SR0 2023-2-28 (Rhino WIP, 8.0.23059.12306, Git hash:master @ 10feece0320668b32d425edee056eb7c5926abb2)
License type: Educational, build 2023-02-28
License details: Cloud Zoo
Expires on: 2023-04-14

Apple macOS Version 13.2.1 (Build 22D68) (Physical RAM: 32Gb)
Mac Model Identifier: MacBookPro18,2
Language: en-AT (MacOS default)

Apple M1 Max (OpenGL ver:4.1 Metal - 83)

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  Anti-alias mode: 4x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: High
  Vendor Name: Apple
  Render version: 4.1
  Shading Language: 4.10
  Maximum Texture size: 16384 x 16384
  Z-Buffer depth: n/a
  Maximum Viewport size: 16384 x 16384
  Total Video Memory: 21845 MB
  Graphics: Apple M1 Max
  Displays: Unknown (255dpi 2x)

Metal GPU Family Apple 7
Metal GPU Family Common 3
Metal GPU Family Mac 2
Graphics processors
  Apple M1 Max
    Color LCD (1728 x 1117 @ 120.00Hz)

USB devices
  Logitech: USB Receiver
  Apple Inc.: iPhone

Bluetooth devices

Third party kernel extensions

Third party plugins

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
  /Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp	"RhinoCycles"	8.0.23059.12306
  /Applications/RhinoWIP.app/Contents/PlugIns/SectionTools.rhp	"SectionTools"	8.0.23059.1002
  /Applications/RhinoWIP.app/Contents/PlugIns/NamedSnapshots.rhp	"Snapshots"	8.0.23059.1002
  /Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoRoslyn.rhp	"RhinoRoslyn"	8.0.23059.12306
  /Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/ConstraintsUI.rhp	"Constraints UI"	8.0.23059.12306
  /Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp	"Grasshopper"	8.0.23059.12306
  /Applications/RhinoWIP.app/Contents/PlugIns/PanelingTools.rhp	"PanelingTools"	8.0.23059.1002
  /Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp	"Commands"	8.0.23059.12306
  /Applications/RhinoWIP.app/Contents/Frameworks/RhMaterialEditor.framework	"Renderer Development Kit"	8.0.23059.1002
  /Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCPython.rhp	"RhinoCPython"	8.0.23059.12306
  /Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp	"RDK_EtoUI"	8.0.23059.12306
  /Applications/RhinoWIP.app/Contents/PlugIns/Displacement.rhp	"Displacement"	8.0.23059.1002
  /Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoRenderCycles.rhp	"Rhino Render"	8.0.23059.12306
  /Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp	"IronPython"	8.0.23059.12306
  /Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCodePlugin.rhp	"RhinoCodePlugin"	8.0.23059.12306