Weird Holes creation

Hi, I have recently started using the Lands Design plug-in. And so far, it’s quite interesting. However, I have hit a wall when it comes to making a simple action such as a hole. My void is an irregular shape and no matter the height of that hole, my terrain starts to create different other random holes. I’m not sure what I’m doing wrong.

Hi @jojs2701, can you provide a screenshot, or even better, the 3dm file of what you are getting? That way we can better figure out what’s happening.

Sure, so the red closed area is the area I was trying to substract from.
TERRAIN.3dm (9.8 MB)

I think the hole is failing because of a lack of precision. You have large coordinate values and the document units set to milimeters. This results in large integer parts which, I think, could be reducing the floating point arithmetic accuracy. I’ve tried to change it to meters and redo the terrain (scaling the terrain is not enough because it just modifies its transformation matrix, while internal data remains unchanged). It works fine now.
So, the steps I followed are:

  1. delete the terrain object
  2. change the document units to meters
  3. say yes to scale geometry, so the curves are scaled to the new units (keeping its logical size)
  4. create the terrain again with those curves
  5. add the hole. It is accurate now

Thank you! I will definitely try that again and let you know if it worked! :slight_smile:

It worked! Thank you so much!