Weird Block Edit Bug

I was working in two different files and while I was editing a block in one, I changed the window to the other file and I saw that some of the objects are locked. I wasn’t using the block edit command on that file and I dont even have blocks there.

When I tried to unlock the objects, I saw that all of them are assigned to random layers and not the layers they were originally in. I tried to close and open the file again but it didnt work.

I cannot reassign all the objects back to their original layers, there are thousands of them. Does this happened to anyone? Do you have any solution to fix it?

Hello - thanks for the heads-up, I’ll check this.
@egecakir - is this in Rhino 5 for mac? So far I cannot repeat it. Is the block embedded or linked?


Hey pascal,

Yes it is Rhino 5 for mac. For me it happened before but I was able to close the document without saving. The whole process was like this:

  1. I opened two different large rhino documents side by side
  2. I used block edit command in one of the files and use make2d to get the lines from the block ( Block is embedded not linked).
  3. I used cmd+x to cut the lines from that file
  4. When I tried to paste the lines to the second document I saw that the objects are locked.

Now I looked at the document more and I saw that the objects on same layer all together moved to a different layer, which I can manually move back.

Hey pascal,

I think I am starting to solve the mystery. So both of my files have similar layers except one file has 5 more layers than the other. ( I use one document to draw the plans & sections and I use the other document to create three dimensional model of it so one has more layers for 3d objects.)

What I figured out is that all the locked objects are moved into the 5. layer above the original layer. I don’t know why this bug happens but I think this is somehow related with the problem.

In addition to this, I can replicate the problem again with the same steps that I took. If you want to check it , I can send you the files.

Hello - please post the files - If they are large or confidential, please post to, and please include a link to this topic in your comments, that will help us keep track of the issue.


Hello again Pascal,

Thanks for helping me out. I tried to upload the files to the link but it asks me to enter a Recipient e-mail address. Without it I can’t upload the files.

Hi - you can use - just make sure to put a link to this thread in the comments.