Objects becoming auto-locked

Hi McNeel,

As the title suggests, I have a bug of objects on a layer in my file becoming locked. This happens on one layer, so I go back into an older file to copy-paste the older version of the now-locked item back into the current one and then I delete the old layer. What happens now is that the locked objects on a layer now moves on to the next layer so the next set of objects becomes unselectable. Not only can I now not select the items anymore but the layer can also not be deleted anymore.

When this happens, the items become a dark grey and I cannot select them. The trouble started when I tried to edit a block in place. I now removed all blocks and re-imported the original block, but before copying it, I exploded the block so it wouldn’t bring any corrupted data with it.

It keeps happening. Eventually I managed to solve the issue by unlocking everything but I am sure that the software is not meant to auto-lock items by itself. Is this a protective feature, a broken file or some error in the software?

Included a screenshot of the individual items being greyed out and locked on multiple layers all visible and the layers are not locked while I haven’t even selected them in that session.

If I recall correctly, there is a bug in the in-place block editor (BlockEdit) that can leave items locked if it fails. As far as I know, there is nothing else that causes this. The only solution right now (before the bug is fixed, and that probably won’t be until V6 for Mac) is to use Unlock or UnlockSelected to unlock the “stuck” objects. The file and the objects themselves are not corrupted as far as I know.

1 Like

Yes that’s what probably happened. I tried editing in place and then it copied a locked version of the block that I tried to edit in place and I wasn’t able to edit the block in place. After that if just kept expanding to the other objects that were not blocks. And eventually everything became locked except for the objects that I copied out of my older version of the file.