Locked block /layer/object/ bug?

Hi!
Struggling with locked blocks.

Let’s say I have two same red geometries (curves) placed on the Layer one (pic 1)
1

I create a block out of the right one. Then I lock the layer, where the block is placed. It is greyed out, but I can apparently still move the object.
3

When I lock the object using the lock command (not locking the layer), the block is locked but does not grey out.

Hey ho, anybody on this? @dan @pascal @wim

@pascal Can you please look into this issue? I’m swamped.

I am not able to reproduce this on a first try at least - as soon as I lock, selection is lost - @petumatr can you send me that you’ve got that does this? I can imagine there is a detail missing from my test,.

-Pascal

Hi @pascal, I will send you the test file with steps as soon as I got myself to mac at work :slight_smile: If that is what you ask for?

Yes, please.

-Pascal

Hi @pascal

Here is the file and steps what I meant…locked blocks issue.3dm (2.7 MB)

Let me know if you struggle with reproducing it.

  • One more issue with the same file, I don’t know if I should create new topic for that?

When the block sits in the default layer with all the properties of the object (colour, linetype etc.) set to ByParent, It does not reflect the changes made in the detail in Layouts. See the picture, shouldn’t the right curve ‘block’ be also blue? Or is this one of the weaknesses of the blocks?

locked blocks issue.3dm (2.7 MB)

@petumatr - thanks - the steps are what I understood… what I am missing is, how are you making the selection to move the should-be-locked object? Can you click on it and have that gumball show up?

-Pascal

well I just click the locked block and the gumball shows up. The move command works as well…How about the _Lock command, can you see the same? 4th pic

I also tried that in WIP7, I can experience it there as well…

Are you trying it on mac?

Hello - yeah, on a mac - I cannot see how a selection is allowed of the locked block… it is not allowed here, with your file. If you open the file you posted and click on one of the locked objects, do you get a selection?

-Pascal

Ok this is weird. I tried to reopen the file I sent you and the block behaves as it should. So I tried to create a new ‘identical’ file and have the same problem. Even after saving and reopening the new file, I tried to restart and it does not help. I guess you cannot reproduce it with creating a new file on your mac…?

Hi @pascal! Any ideas?

This is probably meaningless but do you typically have more than one file open? Does having one or more than one open make any difference?

-Pascal

Nope, not normally. :frowning: