Weird behavior when aligning groups of objects (Rhino 7)

Weird behavior when aligning groups of objects (Rhino 7) as i mintioned in topic :relaxed:
it behaves as if some groups are not groups at all

Hello - please post an example file that shows the problem.

-Pascal

7535.3.3dm (295.8 KB)
Here it is. But this bug appears in any other document.
Rhino Version
(7.5.21053.15001, 2021-02-22)

same here, I also have problems with aligning groups
in the picture below you see 16 groups:


after aligning to the right it is like this:

when I align them seperate, and after that, I align them together, it works again.

hope you can solve this, I use it a lot!

1 Like

aligning.3dm (6.6 MB)
I exported the items, opened the file and tried aligning again, and then it works fine :relieved:.
the original file is too big to send…

Hoi -

So far, I can’t see any difference in behavior between Rhino 6 and Rhino 7.
You can upload bigger files to Rhino - Upload to Support but you will need to explain in great detail which steps need to be taken on which objects. Wading through big scenes and trying to figure out what a user might be doing is a nightmare…
Also, when you upload, provide the url to this discussion in the “Comments” field.
-wim

Still no solution? I have the same bug in almost all my projects, because I use alignment and distribution tools all the time. It appears sometimes, randomly. Same error with the distribution tool!
111.3dm (190.0 KB)

Hello - your objects are members of multiple overlapping groups. I can imagine this makes it all somewhat unpredictable.

-Pascal

In Rhino 6 it’s totaly predictable =)

Hello - here is what I get in V6 and 7 , both, with Align > Bottom:

If I remove all the grouping and group once, I get this:

image

-Pascal

Oh, this means that this bug exists in both versions of Rhino, and something still needs to be done about it.
Remove all grouping is not a solution for me, because I need this hierarchy to be edited in later design stages.