Grouping objects but added other objects into the group

Hi guys! I am having an issue with grouping objects. When I group, rhino always add other objects to the group even though I did not select them. I tried locking other objects, locking layers and such, but nothing works. Everything is in the same group now, not even parent and child groups. Please help me understand what is wrong and how should I fix it! Thanks a lot!!

Maybe the objects you’re trying to group are already grouped? Hard to tell what the problem is without a file

Hello - please post a simple example that shows this, I’ll take a look.

-Pascal


in this image, the red things are grouped, and I want to group the orange things together as a separate group;

I only select the orange things and type group;

and some how the group of red and group of orange become one group…

This is a link to the file, please take a look if you have a chance! Thank you guys so much!

-Rhoda


in this image, the red things are grouped, and I want to group the orange things together as a separate group;

I only select the orange things and type group;

and some how the group of red and group of orange become one group…

This is a link to the file, please take a look if you have a chance! Thank you guys so much!

-Rhoda

I just updated the sharing setting you should be able to access the file now.

Thank you!
Rhoda

Hi Rhoda - as the file opens, there are two existing groups - each contains some of the res objects. If I select all the reds I can group them and if I select all the oranges, I can group them separately, as expected. But here the oranges are more contained, off to one side, than what you show.

image

Incidentally, you might want to look into using blocks for repeated elements - https://wiki.mcneel.com/rhino/usingblocks

-Pascal