'Website not found' when opening Rhino account

I have just downloaded the trial version of Rhino 6 for Mac.
When setting up my online account (it says I have one set up already), I enter my password and then get the message ‘website not found’.
How can I solve this?

Hoi Tine - does this problem persist?
https://accounts.rhino3d.com/ seems to be working fine from here.

It looks like you were successful in setting up a Rhino login account and adding your license to your Personal Cloud Zoo licenses.

Then a few minutes later, you tried to add the same license “stand-alone” to a your Mac. That isn’t allowed.
Instead, you want to click on the “Login” button on any computer where you want to use your 90-day V6 evaluation license.

Any luck?

Hello John,

I still can’t log in, that one webpage cannot be found by my Mac.

I can see the license page, and went there to delete the licence key from Cloud Zoo, I installed the license as a stand-alone now.

Would be great though, if I could benefit from CloudZoo.

Many thanks!


Are you behind a firewall?
If so, give these details to your IT department to see if they can open up a couple ports:


It looks like I need to reopen this conversation. I managed to use the trial version as a stand-alone, so left it there.
But today bought a new license key, and am running into the same problem again.
I can log into my account, and have updated the licence key.
When I open Rhino, and click on ‘log-in’, it sends me to a page where I enter my password, after which I get the message from my browser (firefox) that it cannot find the server/website.
I’m not behind a firewall that I’m aware of (working from home at the moment, no IT department here), and have enabled pop-ups for https://accounts.rhino3d.com.

I can access it from here (also Firefox), no problem… Have you tried a different browser or clearing your browser cache?

So strange…
Safari gives me the same message in another format.

oh, I just realised I made it even more complicated by forgetting that I created an account last time with a different email address to this time. Sorry!

I deleted the old account, and double checked that the correct licence is in the new account.
I received a warning that logged in to my account through Safari, and I can access all my details there… But still no luck activating the software through the log-in.

Creating two accounts is a not a good idea, the system does not like it. It may be that somebody at McNeel needs to have a look in that case. @Bernat, @John_Brock ?

1 Like

I see a Rhino account setup to use the same email address as you are using here in Discourse.
It has a V6 upgrade license in it.
There is no V6 eval license in it.
My guess is you added the eval to a different account, setting up this confusion.

It looks to me like you’re sorted now as I see recent activity in this account.

The part people forget is there is a 2-week local lease that is uses as a “buffer” for when you don’t have Internet access.
The key is to run the “Logout” command in Rhino V6, to kill the local lease.
Then when you start Rhino and login, you can connect to the correct account.

The basic flaw here is the only way we have to identify users is your email address.
If you setup to different account using different addresses, you are two different people to our systems. That can be very confusing.

Thank you John, I really appreciate your efforts and patience with me.

I understand it was very unwise to create a new account.
This new one has the same issue as the previous one though.
When I open Rhino, it does not give me an option to ‘log out’, only to ‘log in’, or to ‘enter a licence key’, ‘use the Zoo’ or ‘buy a licence key’ (or help me decide).
When I click on the log in-button, it does send me to a login-page with the correct account, but after entering my password it says ‘server not found’.
If I log in to the account through the confirmation mail I was sent, I can see and adapt all choices, and enter licence keys.

It’s very frustrating, but I understand that there is not much more you can do if it all works fine for you when you check the system. Maybe there’s some security feature on y computer that I have not yet discovered and unabled for Rhino.
If it cannot be sorted, I’ll switch over to stand alone, that sorts it in a different way.


Make sure the account address is the right one.
If it’s not, I think there is a Change Account option.

Logout is a Rhino 6 command.

Thank you.

I checked it is the right account, and I opened Rhino in the ‘no saving possible’ mode to give the Logout command. Still the same issue…

I’m reluctant to suggest screenshots in this case.
I think your best option is to call Barcelona tech support for live support to figure this out.

1 Like

I’m still confused about this “no save possible” mode.

There is no such thing, unless there is a Rhino Lock file (.rhl) in the same folder. These are created to keep multiple Rhino users from overwriting each other’s changes.

This file locking has nothing to do with licensing.

When I fail to enter the licence key 4 or 5 times in a row, it opens in trial-mode, where I can draw but not save.

I’ll try calling Barcelona.
Thank you for your help with this strange topic!