Weave Generated Points to get the Surface

Hi,

I have a model which has a “mountain fold” at the right hand corner of a plane surface. I’ve modelled it by splitting the surface into 3 parts in order to get the desired surface form. Below show that the points is at the desired positions. However, when I weave the points, I face the issue of generated the desired surface form.

image

I have tried 2 methods of weaving. The first method is by directly weaving the points and the expression there has been change to x+1 for the U count. However, the “Surface from Points” command show the warning message as " A point in the grid is null. Fitting operation is aborted".

image

The 2nd method I tried is by converting the points to mesh, then weave it by “Weaverbird Join Mesh and Weld”. However, the meshing generated is not the desired surface pattern as it have many lines accumulate to a point and the Weaverbird command show error “1. WbProcessingException: Two consecutive edges, 3 and 0, have the same value,0, in face 0. This topology is invalid. Try using Weaverbird’s Clean Up Mesh first. - Weaverbird was unable to produce a valid result because of this”
image

Does anyone have the experience of this weaving points problem after done modelling by surface splitting? (Attached here also the grasshopper script if there is anyone could try giving the advice for solving it)

1. Model 1 Part 1 Pull Point and Weave.gh (32.2 KB)

Thank you.

Best Regards
Yen



Tongteongyen.gh (16.7 KB)

3 Likes

I guess may be “weave” command which I previously use is not suitable for splitting surface. Thanks @Mahdiyar for your amended script :smiley: