Vray for Rhino 3.0 batchrender option?

Since our company upgraded to Vray 3.0 for Rhino, I haven’t been able to find the batchrender checkbox in the new interface, and as a result the entire Rhino window will stay frozen until the render is done, can anyone enlighten me as where it is or is that option gone?

Hi Jun_Wang,

Do you need something else than the standard Batch Render button?

see: https://docs.chaosgroup.com/display/VRAYRHINO/V-Ray+Batch+Render

Cheers
Jonas

Hi Jonish,

Thanks for the info. I know of this batch render function, however this is not what I meant. Back in Vray 2.0, there was this “batchrender” checkbox in settings which can freeze the main Rhino window while rendering so that multiple renderings can be done via scripts; and one can uncheck this box and as a result you Rhino main window will be accessible during rendering so you can render and work at the same time.

After I upgrade to Vray 3.0, I can’t find this checkbox anymore and the rendering process will always freeze the main Rhino window and it’s problematic in situation where I want to work and render at the same time.

Hope that clarifies it.

I have no idea, sorry. You can still uncheck some threads on the CPU and work in different window.

Best ask here

https://forums.chaosgroup.com/forum/v-ray-for-rhino-forums/v-ray-for-rhino-bugs

VfR3 should automatic handle it, but sounds like it’s not right working.

I don’t think it’s a bug.

Also we should not forget - some options are not accessible through the UI but still active. So, maybe the old option is still active. It can help to save the visopt, edit the file/option per text editor, save it and load it back to rhino again.

thnx for the advice, found a related thread here:
https://forums.chaosgroup.com/forum/v-ray-for-rhino-forums/v-ray-for-rhino-general/75975-is-v-ray-3-rhino-supporting-the-animation-rendering

We removed the batch render option in V-Ray 3 for Rhino, We auto detect if you are in an animation command, and wait until render is finished if needed. There is a bug in this code, Until we fix this bug, run the below code in the command prompt before recording a bongo animation.

!-_RunScript (
Option Explicit
Dim VRay
Set VRay = Rhino.GetPluginObject("V-Ray for Rhino")
VRay.SetBatchRenderOn True
)

Guess just have to wait.

editing the visopt via text editor is a nice idea, I just don’t think changing it manually every time I need to batch render several scenes is an efficient workflow, I think I will just write a macro render button that will have a script component that does below code before a render command is called, and use that button only for single test renderings and remain the ability to run batch render via a different button:

VRay = Rhino.GetPluginObject("V-Ray for Rhino")
Vray.SetBatchRenderOn False

thank you both.