Viewports disappear from Layout when printing?

Hello again!

I’m having a strange issue when printing: when I print (to various printers including PDF), my file suddenly does not show the viewports (vital to the drawings). I’m not sure why, as they were working just yesterday. :confused:
Here is an image to show what I’m talking about. I tried printing to PDF anyway to see if it was just a preview error, but indeed the PDF did not have any of the viewports in the drawing.

Any ideas?
Reboot does not help, nor does DPI seem to have any influence (as was the case in similar thread).

I will also note that the viewports are in a modified 'Arctic" display mode with individual elements having different display modes. Switching viewport display mode does not seem to improve the situation EXCEPT when switching to wireframe, in which case the viewport suddently becomes visible.

Okay, so I’ve managed to get the viewports to appear again, but only when I turn off shadows for Arctic under Display Modes in Options. Does anyone have ideas as to why that is? It would be nice to keep the shadows on, and I’m not sure I’ve ever had an issue with that before.

This could be a display driver issue.
Run the Rhino SystemInfo command and please post the results.

Try the output in raster mode.

Rhino 6 SR22 2020-1-28 (Rhino 6, 6.22.20028.13281, Git hash:master @ 379871ece695dc096e83826f08b429db8ca2e7f5)
License type: Commercial, build 2020-01-28
License details: Cloud Zoo. In use by: christlewis ()

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: DESKTOP-3R373IO

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1050 Ti (NVidia) Memory: 4GB, Driver date: 7-24-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 432.00

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-24-2019
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Output in raster mode is worse: the entire page goes blank.

Here’s the current driver from earlier this month:

Choose the Advanced option and select a “Clean” install.

Any better?

I’ve updated the driver as per your suggestion, but unfortunately it hasn’t changed anything.