Layout to PDF does not print viewport content

Hi there,

Problem: Rhino refuses to print my viewports to pdf, or JPEG or anything else.

I’ve tried toggling all of the options in the print menu, no improvements
I’ve tried disabling vray5 , no dice
I’ve tried all of the view modes from shaded to rendered. No difference.
I’ve tried saving the file and rebooting Rhino with no luck

Is there some esoteric mysterious unlocatable checkbox to enable the viewports for printing or anything?
Vector or Raster mode does not make any difference
The hatches and annotations which I’ve drawn on top of the viewport do show.
The viewports do not show

Thanks in advance

Hi -

From that image, it seems like you are referring to a post from 2015??

I’m afraid a screenshot is of little help.
Please attach a simple file that shows this behavior on your machine, run the Rhino SystemInfo command and copy-paste the result here.


Ok so I;ve managed to obtain some results after the following steps

I’ve updated my Nvidia RTX 2060 Drivers to the latest studio version
I’ve rebooted my computer
I’ve rebooted Rhino without disabling any plugins or changing any settings

My previous layout still doesnt print any viewports I’ve manually added these viewports into the layout
I’ve started another layout sheet and adjusted the original 4 viewports to my needs
Now the layout produces the wished results during Print
I’ve also added new viewports with the same desired result.

Again my previous layout still refuses to print

Ive started drawing an annotating on top of de viewports, still good, happy day

Any Idea what I’ve done goofed on the first layout?

Probably nothing… should be only a driver video related problem.
If you want some informations, follow Wim’s request (systeminfo + example file).