Adjust rhino viewport size for output render resolution

hi, is it just me or I am having difficulties on adjusting viewport resolution to match with Maxwell camera setting?
I set maxwell camera resolution to sync with rhino viewport, however everytime I accidentaly “drag” the side tool tab, my view port resolution changes, is there a way to “edit” view port resolution let say I want it in 1:2 ratio, lock the ratio and save it in [named views] tab?
since I am using plug in render maxwell, it doesnt override rhino camera setting, which i find quite annoying :frowning:

help me pls

Hi Runnie- I would make a NewFloatingVieport to be the rendering vp. Does that work better. You can set VP size explicitly using the

 -ViewportProperties Size

-Pascal

hi Pascal, thanks for the quick reply. Iam still having a trouble mainly because rhino viewport size is based on computer pixel size (depends on your monitor size)
let say I want to see the model on the viewport ratio of 1:2 because maxwell will use my viewport size for it’s output rendering resolution. it can never be bigger than my monitor resolution. (not to mention if I change computer, the viewport size will keep changing) and if I change the rendering output resolution in maxwell, it doesnt display the changes in Rhino viewport, because maxwell plug in camera Does not override rhino’s.
that is the main problem for me, I can never work on different computer when working with maxwell. because the only way to match maxwell camera and rhino camera is by using rhino’s viewport resolution.
or maybe I missed some important command in rhino? any suggestion?

another simple case I would like to know:
let say if I have this current view on my viewport =

and then somehow I want to invert the view ratio = instead of W/H 2:1, I want it to be W/H 1:2 and I am quite happy with the camera location so I dont wanna move my camera, is there a way to achieve that?

thanks

I follow your instruction, but I cant seem to edit viewport size in the new floating viewport properties

or maybe I did it wrong?

Hi Runnie- use the scriptable ‘dash’ version of the ViewportProperties command -

-ViewportProperties

-Pascal

it works, fantastic! thanks mate

Hi Runnie,
Maxwell with the HUD (Maxwell_ToggleCameraHeadsUpDisplay) and the Camera Back Panel (Maxwell_ToggleCameraBackPanel) offers a very nice way to keep your Camera Views without ever having to resize the the viewport to a specific size and aspect ratio. Just check the Rhino Help section in Maxwell’s Online Docs.

Hello guys,
Once, I have been able to change the resolution of a viewport up to 4K (3840x2160px) for sure using :

NewFloatingViewport
-ViewportProperties Size
3840
2160

But rhino crashed one day later, something about unknown error for Nvidia, but I forgot the details.
Now, it seems I cannot go further than 2564x1421px, when I type in the resolution I want (4K) it automatically set it up to the latter max values. What could be wrong ?
This is for making captures and animations directly from the Viewport with High-Resolution.
My Monitor is a Dell 2560x1440px.
Thanks!

Hello - yeah, it looks like you cannot make a viewport larger than the screen… but render resolution is not constrained by that.

-Pascal

Hello Pascal,

This is annoying, knowing I have been able to do it a few days before (with the same machine and same display monitor). I checked and indeed, I managed to make an animation using a custom floating viewport 3840x2160px. I placed the floating viewport in a corner with a saved named view, so I was able to work with standard views and with a smaller viewport with the latter named view. So for captures and animations, I just had to select the top-left corner.

I’d like to avoid going through any render. This is really about viewport captures, knowing I am working with custom displays using grasshopper.

And rhino seems to be able to display a viewport even bigger… in my previous post you can see that the maximum viewport size is 32768x32768 with my Nvidia Quadro P1000.

Is it possible that Windows 10 is constraining any window to a maximum, basically the display monitor max resolution? An update might have had an effect on this.

Thank you !

1 Like

@LaurentB any news on max viewport resolution larger then screen on win10?

Hello,

I am also looking to increase the viewport for a render, but the -viewportProperties command does not let me change the size of the viewport. It lets me change some other properties but when I click on ‘size’ the command ends itself :frowning_face:

I am using Rhino 5 for Mac, could it be that you can only edit the viewport size on a Windows?

Please let me know if anyone has any idea, I’m desperate :frowning:

Valeria

You don’t need to change the viewport size for a render, you can adjust the resolution and size in the Render section of Document Properties:

Thanks Helvetosaur,

Do you know how I can access this on a Mac? I can’t find Rhino Options.

My issue is that I cannot control what goes into the view when I change the viewport size manually in the render settings, so I am hoping to increase the viewport itself and then render current viewport.

I don’t need the resolution to be very high as I am using the view to photoshop over, but I do need the basic geometry.

Thank you so much!

This post is under the Rhino for Windows category, hence the answer… You should find similar settings under File>Settings>Rhino Render, check the radio button for for custom resolution and enter a resolution…

Thanks for the answer, I commented here because generally the solutions for windows and mac are transferable…

Thank you!