Viewport rendering issues, views are just blank white


#1

I’ve been having problems with the viewport not rendering correctly, and just displaying white.

The views will temporarily come back if I scroll or interact with each view, but they tend to flash back and forth as I work within the application.

I’m currently using 2014-02-11, but I have been noticing this behavior in the last few versions.


#2

maybe an older intel gpu?

go Rhinoceros-> Preferences-> OpenGL
at the bottom of the openGL window, press ‘copy to clipboard’ then paste here


#3

weird… a little bit after posting that :point_up: ,i came across this file which opens similarly to your screenshot (in contents/ resources)

Untitled.3dm (10.1 KB)


@paige ,what happens if you open this file? :point_down:
tryThisOne.3dm (105.1 KB)


#4

When I first opened it, it didn’t have any issues. But in another file (included below), I copied the screw, and pasted it into a new file, and then I immediately got white in one of the viewports. When I switched back to tryThisOne.3dm, it also started showing the white view ports again.

0-80_Screws.3dm (1.0 MB)

Here’s my machine info, copied from the OpenGL preferences window:

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-02-11 (502)
OS X version: Version 10.9.1 (Build 13B42)

Plug-ins
None

Hardware information

Computer hardware
Hardware model: iMac11,3
Processor: Intel Core i3 CPU 550 @ 3.20GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: ATI Radeon HD 5670 512 MB
Memory: 512 MB
Screen size: 2560 x 1440, 1360 x 768
Displays: iMac, hp PL5060N

USB devices
Generic: USB2.0-CRW
Apple Inc.: Bluetooth USB Host Controller
Apple: Internal Memory Card Reader
Logitech: USB Receiver
Apple Computer, Inc.: IR Receiver
Apple Inc.: Built-in iSight

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 ATI-1.14.21
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 2x
Mip map filtering: None
Anisotropic filtering: None


#5

hmm… yeah, that file works fine for me and i’ve never had a viewport whiteout like you’re showing while in the middle of a drawing session… (there’s a difference in the two screenshots above- mine doesn’t have viewport labels in there… it’s maybe more of an incompatible(?) .3dm whereas yours appears to be a gpu related glitch.

regardless, this is beyond me… @marlin will have to look into it as he will have an actual clue as to what the problem may be.


#6

Ok, thanks for looking. Let me know if there’s any more info I can provide.

~paige


(Marlin Prowell) #7

There are two different issues here. Jeff found a malformed Untitled.3dm lurking inside the Rhinoceros application. This file is no longer used, and also has some bad viewport positioning information in it. The new UI pays attention to the viewport positions stored in the 3DM file, while the previous UI versions did not. That’s why three of the viewports have no label - there is no viewport at all in that quadrant. Pay no attention to that file. It will be gone in a future WIP release.

Paige’s problem is different and likely the GPU is running out of graphics memory. To get speed, Rhino uses a lot of memory and resources on the graphics chip. Blank viewports with labels looks like there is not enough graphics memory to keep copies of the viewport on the GPU chip.

The GPU needs to share its memory with all the Rhino windows and with all the other applications running at the same time. Plus, I see that you have two displays. Everything displayed on the second display also needs graphics memory.

So, things to try:
Close other Rhino modeling windows except the one you are working on.
Close other applications.
Unplug the second monitor.
In Rhinoceros > Preferences > OpenGL, set Anti-aliasing to none.

Try these things, perhaps one or more at a time, to see what makes a difference. Restart Rhino each time when testing. These are not meant to be final solutions, but to help test the graphics memory hypothesis, to see if that really is the problem.


#8

I was able to recreate the issue by copying the objects in the file I attached above, and pasting them into a new file.

It seems to be fixed now however, after I closed all of my extra desktops!
But before I did that, I had tried unplugging the extra monitor and restarting
but it didn’t seem to be enough.

I also added a few desktops back and it continues to draw correctly now.

Resolved for now, and one more reason I might need to upgrade soon… :slight_smile:
Thanks!
~paige


(Marlin Prowell) #9

Ahh, yes, extra desktops would also strain the graphics memory usage. Rhino for Mac could have, but does not yet have, a fallback scheme when the computer runs out of graphics memory. This fallback would slow down drawing in Rhino, but at least the program would be usable.

I just looked, and, these days you can get iMacs with 2GB or 4GB of graphics memory. That’s pretty amazing, and is plenty of graphics memory to have multiple displays and multiple desktops, and whatever else you want to load into the computer.


#10

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-02-18 (503)
OS X version: Versione 10.9.1 (Build 13B42)

Plug-ins
/Library/ScriptingAdditions/SIMBL.osax/Contents/MacOS/SIMBL
/Users/simoneplai/Library/Application Support/SIMBL/Plugins/Afloat.bundle/Contents/MacOS/Afloat

Hardware information

Computer hardware
Hardware model: iMac13,2
Processor: Intel Core i5-3470 CPU @ 3.20GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GTX 680MX 2048 MB
Memory: 2048 MB
Screen size: 2560 x 1440
Displays: iMac

USB devices
Western Digital: My Passport 0748
Wacom Co.,Ltd.: CTH-460
HP: Photosmart C4700 series
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
Apple: Apple Wireless Trackpad
Apple: Apple Wireless Keyboard

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-8.18.22 310.40.05f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: Nessuno
Mip map filtering: Nessuno
Anisotropic filtering: Nessuno
To solve the problem temporarily, before the gate menu “recent files”, then save your work, then close the file and reopen it.


(Marlin Prowell) #11

@Zsimon, please try the different things I mentioned in an earlier post in this thread and see if any of them make a difference in the viewport flashing.


#12

@marlin Any idea how to fix the “bad viewport positioning” you mention? A file of mine has this problem - with two viewports unusable. Screencap attached.

Thanks


(Marlin Prowell) #13

Post post the model or send it to us. See the Reporting Problems with Mac Rhino post for more details.