Viewport are not working

Hello,
Since few days/weeks, when I open a rhino file with Rhino 6, rhino only display the last selected viewport. This viewport is 100% working.
However, all other viewports are being deleted.

When I try to open a new file, there is no viewport being created.
When I try creating manually a viewport, this happens:

Command: NewViewport
Error creating new viewport

I try launching try Rhino with both GPU and Intel chipset. In both cases isn’t working.
All drivers seem updated.

Do you have any ideas on how to solve this issue?

Many thanks

Best regards,
Nicolas Père

Ps here my info :

Rhino 6 SR16 2019-7-9 (Rhino 6, 6.16.19190.07001, Git hash:master @ a8b4ee102e9e0eb1d11825df063e13f96d518f93)
License type: Commercial, build 2019-07-09
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: PESD-FR-0001

Non-hybrid graphics.
Primary display and OpenGL: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 3-8-2019 (M-D-Y). OpenGL Ver: 4.5.0 - Build 25.20.100.6617

Secondary graphics devices.
NVIDIA GeForce GTX 1050 Ti with Max-Q Design (NVidia) Memory: 4GB, Driver date: 4-23-2019 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.5
Shading Language: 4.50 - Build 25.20.100.6617
Driver Date: 3-8-2019
Driver Version: 25.20.100.6617
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\KeyShot8RhinoPlugin (6c7d7caf-b4ba-406d-bfaa-8d719d8212c3)\1.0.0.0\KeyShot8RhinoPlugin\Rhino 5.0\KeyShot8RhinoPlugin.rhp “KeyShot8RhinoPlugin” 1.0.0.0
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - try setting the Nvidia control panel to use ‘High performance’ - this should force Rhino to use the Nvidia gpu rather than the Intel.

-Pascal

Hello Pascal,

Thank you for you swift reply.
Sadly, even when using the Nvidia GPU it is still not working (see below)
Hovewer the primary display is still powered by the Intel GPU, is that ok ?

This is what happen when I open an existing file, only the selected viewport is displayed:

When I open a new file, everything on the viewport is black

For information, it was working perfectly for almost one year, but i don’t what changed since (Rhino, drivers or Windows update maybe?).

Best regards,
Nicolas Père

PS :
Rhino 6 SR16 2019-7-9 (Rhino 6, 6.16.19190.07001, Git hash:master @ a8b4ee102e9e0eb1d11825df063e13f96d518f93)
License type: Commercial, build 2019-07-09
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: PESD-FR-0001

Hybrid graphics system.
Primary display: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 3-8-2019 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 1050 Ti with Max-Q Design (NVidia) Memory: 4GB, Driver date: 4-23-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 425.45

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-23-2019
Driver Version: 25.21.14.2545
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\KeyShot8RhinoPlugin (6c7d7caf-b4ba-406d-bfaa-8d719d8212c3)\1.0.0.0\KeyShot8RhinoPlugin\Rhino 5.0\KeyShot8RhinoPlugin.rhp “KeyShot8RhinoPlugin” 1.0.0.0
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi - it’s the “primary OpenGL” that is important and so that looks good for your system now.
Are the viewports correctly drawn when you start Rhino in safe mode?
-wim

Hi,
It’s working in safe mode, viewport are displaying proprely

Best regards,
Nicolas Père

I just restart Rhino is standard mode. It seems to work well so far.

It’s strange that starting Rhino in safe solved the issue in regular mode, but it works so this is great.
Many thanks for your help

Best regards
Nicolas