Some Viewports are not refreshing

I am new to Rhino. Recently installed v6 on my Win 7 Pro desktop. I am following some basic YouTube tutorials. When I draw a simple rectangle on the Top viewport, I see it created, but the Perspective viewport fails to update, and in fact, as I toggle from Rhino to my browser and then back to Rhino, (some of) the viewports will display the content of the browser that had been showing when the browser had focus. I have tried various resizing options of the Rhino screen, but the viewports fail to display what should be exclusively Rhino renderings.

Machine performance is basically idling @ 10% of memory used and CPU @ 0.1%

Seems to me as GPU related problem. I would try to install latest drivers it helped me few years ago.

Hi @jmc
Run the SystemInfo command in Rhino and copy/paste the result here - but as @Lukas_Mateja mentions, there’s a good chance an updated grahics driver will help.
HTH, Jakob

The graphical glitch sounds like a Radeon HD GPU, older model. Maybe 7xxx series?

Rhino 6 SR28 2020-7-17 (Rhino 6, 6.28.20199.17141, Git hash:master @
License type: Educational, build 2020-07-17
License details: Cloud Zoo. In use by: John Chambers ()

Windows 7 SP1 (Physical RAM: 12Gb)
Machine name: JOHN-PC

Non-hybrid graphics.
Primary display and OpenGL: ATI Radeon HD 4800 Series (AMD) Memory: 1GB,
Driver date: 7-3-2012 (M-D-Y). OpenGL Ver: 3.3.11653 Compatibility
Profile Context

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 3.3
Shading Language: 3.30
Driver Date: 7-3-2012
Driver Version: 8.970.100.3000
Maximum Texture size: 8192 x 8192
Z-Buffer depth: 24 bits
Maximum Viewport size: 8192 x 8192
Total Video Memory: 1 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development
Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”


your graphics card is ancient, only has 1gb of vram- with an ancient driver.

time for an upgrade, or at least a new driver.

I have at home also an old Radeon HD, just a bit newer than yours (7xxx series). We have tried many, many, many things to get Rhino working on it, but this old series 7xxx and before, including your 4800, just refuses to work well with Rhino. I am afraid Rhino 6 (and Rhino WIP) will not work properly on these GPUs :confused:

Thanks for your info. I guess it’s time to start looking to upgrade.