Viewcapturetofile problems

The viewfilecapturetofile command is not opening up the browse window and nothing appears after typing in the command. I have no idea how to fix this problem.

Hi Ryan - can you please run SystemInfo in Rhino and paste the results here?


Rhino 6 SR9 2018-9-28 (Rhino 6, 6.9.18271.20591, Git hash:master @ 4cf7435f08f51c972347c8558d28355cfc0471ca)
Licence type: Educational, build 2018-09-28
License details: Cloud Zoo. In use by: ryan.haymaker ()

Windows 10.0 SR0.0 or greater (Physical RAM: 7.9Gb)
Machine name: SANDY

GeForce 940MX/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 373.50)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 1-1-2017
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.9.18271.20591
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.9.18271.20591
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.9.18271.20591
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.9.18271.20591
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hmm - nothing leaps out at me there - the video driver is getting on a bit, but I doubt that is the cause here - so the symptom is, you run ViewCaptureToFile and you see no dialog at all?



yes viewcapturetofile has no dialog box but for some reason viewcapturetoclipboard does…

One thing to test is:

  • close all Rhino instances
  • in File explorer browse to %APPDATA%\McNeel\Rhinoceros\6.0\
  • rename the settings folder to settings.original
  • start Rhino
  • try _ViewCaptureToFile

If this works then your settings have for the dialog values that make it essentially invisible. If you don’t mind maybe you could zip up the settings.original folder and attach it here.

I was unable to find %APPDATA\McNeel\Rhinoceros\6.0\ in my file explorer.

Sorry, I typoed, the first part is supposed to be %APPDATA%, note the second percentage symbol.

You are can copy&paste that part into the location field of file explorer.

i was unable to find the settings folder after searching %APPDATA. All i found where a bunch of random files

You didn’t find the folder %APPDATA%\McNeel\Rhinoceros\6.0? It should have folders named UI, settings, Plug-ins and a few others.

within my rhino 6 program file, I only have a system and plugins file.

I have also just uninstalled my rhino 6 and reinstalled it and still no dialog box for my viewcapturetofile. I have tried my rhino projects on other computers as well to see if the file is corrupt but the command works on another computer with rhino 6 so I really don’t know what the problem is.

I think we really need to find the settings folder for Rhino on your machine. I have no access to my office machine now, but tomorrow morning I’ll create an animated gif of what I mean how and where you should look.

System and Plug-ins is in the installation directory under C:\Program Files\Rhino 6, that is not the folder I am looking for.

@ryan.haymaker @nathanletwory

I think this is what you need; “roaming”
edit: :+1: Nathan

1 Like

Yes, typing %APPDATA% in that location bar expands to the Roaming folder under app data.

1 Like

thank you for the help @Fred_C ! @nathanletwory I was able to find the file and i have changed the file name to settings.original and re opened rhino 6, but still again, no dialog box :confused: I have also discovered that the command viewportproperties isn’t opening dialog either.

@ryan.haymaker what viewport mode are you trying to capture with? If it is Raytraced try pressing Alt after you’ve typed the command and pressed Enter.

Hi @ryan.haymaker

viewportproperties doesn’t give you a dialog box, but instead changes the tab to properties>view.

HTH, Jakob

i have tried it in all viewport modes and it hasn’t worked. I tried in raytraced mode then pressed alt and still nothing.