ViewCaptureToFile not keeping proportions or center

I am trying to run view capture to file in Rhino 6

I lock the viewport ratio, but the export somehow trims my view…
I am only changing the scale to achieve a higher quality.



Really frustrating issue…
Model: test.3dm (1.4 MB)

Oh hello there! I wrote here about this issue more than month ago , still no solution.
The only workaround is to use viewport size in drop list and output big res by parts .

I have the same issue. Really frustrating. I hope it will be solved soon.

It happens when viewport is set to two-point perspective.

Hi @ShynnSup & @bigonethegod,

Thank you both for reporting this, and sorry for not picking this up sooner. I can reproduce the problem, and have pinpointed the code change which caused the regression. I made a YouTrack item:

The issue seems to only happen on Parallel views.


I can promise you it also happens in two-point perspective, quite often even but not every time, therefore it is not easy to reproduce.

RH-53656 is fixed in the latest Service Release

1 Like

Thanks Brian. This fixes the image placement issue. However, I am now getting a darker streak running across my captured view. I have repeated this in different files. Wondering if anyone else is experiencing this.

Hello - this looks like a tiling problem, maybe? Are you capturing larger than viewport (pixels) images? What if you just capture the viewport sized image?


Same, this isn’t fixed yet.

This is a tiling problem that seems to be happening sometimes in Parallel/Two Point perspective views. I was able to reproduce the issue and created this:

Hi Pascal,

Yes, it seems to only happen when using custom viewport size without a locked aspect ratio.

I have the same issue! Especially when I view capture the large city axo view. This happens in Rhino 5, 6 and 7. It’s also very wired that the preview is correct but the outcome has this error.

I also run into this issue, it really annoys me and still not really a work around :confused:
I take so much time to get the preview right, just to see the result is something completely different.

Hi -

I can’t reproduce this in a quick test here. Could you post a file that behaves like that and the settings that you use in the command?

Hey :slight_smile:
Sure: I have a sample file attached, you can see in the first screenshot that this is what the interface looks like before saving the shot. The second one is the result.
What is also interesting is that i can also show another issue that i have since a couple of months: Some Materials are transparent when using the ViewCaptureToFile…

Test.3dm (778.4 KB)


Hi Sebastian - here, I see the transparency problem if I ask for transparent background but so far the view is as in the preview (in our latest V7 builds here)

Can you please run SystemInfo in Rhino and copy/paste the output here?