Bug: "ViewCaptureToFile" shows a misleading preview

It’s an old bug but it really gets very irritating when the goal is to make exact captures of the viewport for creating diagrams. The “ViewCaptureToFile” tool shows a misleading preview which is the wrong size compared to the saved image. Here is an example of the preview that Rhino 7 shows me and how the same captured image looks like:

Preview:

Captured image:

Huge difference between the preview and the captured image:

To my understanding, the tiny preview window basically trims the side edges of the visible active viewport to try to show the target aspect ratio, but the saved image actually uses the full width of the viewport and adds extra height to the top and bottom, which is not visible both in the tiny preview and the actual viewport. That makes the captured geometry appear smaller on the image than what the misleading preview hints. A more natural way to execute that would be to fit the captured image to the visible portion of the viewport and remove the unnecessary pixels on either side.
Do you plan to fix that bug in a future update? :slight_smile: I spend an enormous time while trying to fit the 3d model in the desired way. It basically takes me 10-20 trials before I could do the right proportion. This particular aspect ratio is chosen because the captures must be printed on a standard A4 paper format.

Hi Bobi - I will get this on the pile if it is not there already - for now, it may save some angst if you make a new floating viewport that has the aspact ratio of the desired image and set the capture there. Named views can be restored to a new viewport and can restore the aspect ratio.

-Pascal

2 Likes

Hopefully it will be resolved soon! :slight_smile: Meanwhile, I did what you suggested and it works as described. Thanks!

Possible bug: If I set Two point perspective from the Properties panel, it’s literally impossible to control the viewport via 3d mouse in a normal way, because the center of rotation is no longer able to automatically set itself onto the geometry.

Along with the two bugs I already mentioned in this topic (the bug described in my last post and the one in my original post), today I also found two new bugs:

  1. When I run the ! _NewFloatingViewport _Projection _NamedView command (evoking a new floating window from a list of saved Named views), the resulting floating window has a strange coloured frame and leaves some blank space on both, lefts and right. Looks like some sort of a safe frame for rendering. However, the biggest issue with this approach is that it disables my 3d mouse. The latter is able to pan and rotate the view only if I hold the LMB or RMB!

  2. On top of that, the framerate is extremely low even while showing a simple geometry, unlike the basic ! _NewFloatingViewport command which performs normally even with heavy scenes.

Another option is to use the print command with image file as the destination. ViewCaptureToFile is really just a simplified version of Print

It gets really complicated that way. And still needs to adjust the ratio. The floating window is faster in my opinion, though the default “view capture to file” is best. Only needs to be fixed to show a proper preview. :slight_smile: