ViewCaptureToFile in Arctic mode at large scale only in greyscale

viewcapturetofile

#1

Using ViewCaptureToFile in Arctic mode at large scale (Scale setting = 2) results in a greyscale image. Using Scale setting = 1 outputs an color image.



Used Rhino version: R6 SR3 RC2

BTW: Thanks for fixing ViewCaptureToFile of ZBuffer with scales >1! No more tiling artifacts!


(Pascal Golay) #2

Hello - thanks, I’ll check this.
Hm - I see this, thanks - apparently there is a viewport size threshold - I can make the vp smaller and at some point even at scale = 2, where the color survives.

-Pascal


#5

Hey Pascal, thanks for your answer. Would changing the viewport size threshold to scale = 2 result in a max size of the color picture of 3840 x 2160 pixels on a full HD screen? Sometimes I need more than 4K resolution for sharper screenshots (ViewCaptureToFile) with thin colored edges/curves in Arctic mode as replacement for renderings.

Cheers,
David


(Pascal Golay) #6

Hi David - I don’t know if there is a useful workaround for this command until the bug is fixed - I just noticed that a 2x capture works in color up to a certain pixel size of the viewport - above that, the color drops out.
In the meantime, you might try the Print command and set the print destination to Image file.

-Pascal


#7

Hey Pascal,

yay, “print to file” did the job, although it took way longer than ViewCapture. Thanks for your help.

Cheers,
David


(Pascal Golay) #8

Hi David - you may want to lower the dpi setting in the Print dialog.

-Pascal