Viewcapturetofile issue - changing render modes?

unhandled

#1

ViewCaptureToFile is a Great way to get a higher resolution version of what you’re looking at on screen.

I’m in shaded mode and objects have custom colors. But when I do a viewcapturetofile it’s keeping all my settings except it changing all the objects to show as if they had a black color, meaning the lines on them are black, but the objects are displayed as white/light gray. Whatever the default is.

Is this a bug, am I missing a setting? I’m using the dash, so running -ViewCaptureToFile so I can change the scale, choose where it’s saved, adjust transparency settings etc. but I don’t see anything about materials/appearance.


(David Eränen) #2

Hi @kalamazandy,

Which Rhino version are you using? I can’t repeat this in v5 and v6. Can you repeat this bug starting from an empty scene?

-David


#3

image
Version 6, note specific one above. I just checked too, it’s current as of today.

Since you said you couldn’t repeat it I created a new scene.
I created two boxes, and changed one of them to display color yellow. The other, kept to the default black.
On screen capture to file they are both the white color.
I attached that, Just in case.
BoxTest.3dm (244.5 KB)


#4

Well, this doesn’t happen on my coworker’s machine.

I have a few custom settings in my Shaded. I tried turning them off though, and that didn’t change the issue either.

Let me know what to do from here. I’m at the end of my troubleshooting knowledge again. If you need a preference or something like that, please include where to get the file. I can never quite remember which files are where.


(David Eränen) #5

Hi @kalamazandy,

Did you turn off the custom setting by pressing Reset to defaults? If not, please try doing it using the button.


#6

Shoot. I thought I had it figure out. But it appears to be a bug. I just hadn’t given you enough information yet because I didn’t know.

It’s the scale setting.

Funny thing is, I thought it was my computer. BUT I had already done the most recent update. My coworker hadn’t yet. I had him do the same thing, and sure enough; as soon as you change scale to anything but 1, and you get no colors.


(David Eränen) #7

Thanks @kalamazandy! I can reproduce it now.

Here’s the YouTrack item: https://mcneel.myjetbrains.com/youtrack/issue/RH-44227.

-David


(Jack Gaumer) #8

@kalamazandy Did you try changing the “print color” setting in layers? I was having the same issue with any file created in v5 but doing viewcapturetofile in v6. View capture is using the ‘print color’ rather than the object color, which any converted file has automatically set to black (resulting in white shaded objects).