ViewCaptureToFile creates PNGs with grasshopper preview meshes showing as transparent

I am using ViewCaptureToFile to export views containing thousands small mesh objects as .PNGs with transparent backgrounds. The mesh objects are generated in grasshopper and use the Custom Preview component with simple color inputs.

The problem I am having is that meshes previewed in grasshopper are being exported as transparent. The darker the color, the more transparent the object.

The color swatch input into Custom Preview is opaque. The image export is being scaled by 2. I have this problem no matter what the rhino window’s display mode setting. Strangely white color meshes do not have this problem.

The objects are open, planar and simple. Problem occurs with both meshes and surfaces. It occurs with grasshopper components Custom Preview and Custom Preview Materials. When I input the transparency as opaque in Custom Preview Materials it still returns transparent view captures. It seems as though the color value is being used for the transparency setting since darker materials are more transparent.

Current workaround is to bake the meshes but this is very time consuming.

Using Rhino 6 SR23. Problem happening on my laptop and desktop - both have updated graphics drivers.

Follow up:
I misspoke on one item - grasshopper objects do show up as opaque in ViewCaptureToFile when I use rendered display modes.

But… what I really need is the view to be captured just as I am seeing it in the viewport in flat color shading modes. I want the RGB values I am inputting into the preview command to be exactly the color of the objects when I use CaptureViewToFile.

Hi Elijah - I see that here and filed RH-57288 for a developer to take a look at.
Thanks for reporting!

1 Like