Problem with transparency in ViewCaptureToFile


I have reports of a strange bug from my colleagues - a .png image generated by the _ViewCaptureToFile command simply translates black (and shades of gray) as transparency with the exception of shadows. Is this some kind of setting that can be turned off? It´s not that the PBR material used has transparency, because you can´t see to the other side of the object. It´s probably something computed after the initial image is rendered.

Another strange thing is that the environment included below doesn´t unpack, although I´ve checked the “Yes” on the include support files dialogue:


environment.renv (4.8 MB)

Unfortunately, I can not recreate the problem on my machine where everything runs fine. (probably because I authored all the files)

Is the only answer blindly overwritting their setting with mine? I´m not sure everyone would like that, haha.

Thank you for all your tips and have a nice day

1 Like

Hello @kral,

I seem to have that issue, too. Maybe take a look and confirm if that is the same problem?

1 Like

This indeed is the same problem. I´ve turned on notifications on your post and hopefully someone will notice us. :wink:

1 Like

I’m having the same issue!

Hi -

This is now on the list as RH-70307 ViewCapture: Materials become transparent

1 Like

Thank you. I checked on the report and it mentions “dark plastic material”. If it´s material type related issue I´d be glad if it mentioned PBR material as well.

ViewCapturePBR.3dm (4.7 MB)

RH-70307 is fixed in Rhino 7 Service Release 23