Video by a frame range is out of the range set (by a few frames)

Hi everyone once again,

I am trying to render an animation in Bongo. I set the timeline to 80 ticks,
and set in the Bongo Document settings the “Timeline length in seconds” parameter to 80

When I export a part of about 12 seconds the last frame should have a still image like many of the previous frames (4 seconds of a still video image), after that frame the object starts moving again and from that time I need to have a separate video.
So I get the encoded video and by the end of it- the object is starting to move again which I don’t want and it shouldn’t happen by the frame ranges I set and also doesn’t happen while running the timeline and reviewing the animation…

so I figured the timeline starts with 0 so the time should be set back in 1 second, but still, it didn’t solve the problem. It shortened the time it should’ve had in that part where the object is still in 2 seconds instead of 4.
I am rendering 15 frames per second.

What am I doing wrong?
Thanks a lot!

Hi Roy, still working on your project, eh.:wink:

The enigma of the timeline starting at zero is easily solved by comparing it to a ruler. The zero doesn’t count.

At 0 you have zero centimeters. At 10 you have 10 cm although there are 11 markings (0,1,2,3,…,9,10)
In the frame numbering however zero counts: frame 000 is the first and frame 99 is the 100th.
Can be confusing.

But I don’t see how this can cause your problem. As far as I can see, when the object isn’t moving yet at e.g. tick 12 and you render from 0 (start) to 12 (end) the video shouldn’t show a restart. No even when you tampered with tweening settings.
Can you show us the model? When it is confidential you can send it via on behalf of

PS. I don’t understand what you mean by:

Or maybe better Roy, discribe exactly how you go about making the 12 sec segment of your 80secs animation.
And show us a screenshot of Bongo’s Render Animation dialog with the settings you apply.

Thanks for your help @Luc, yes still working on it… not so easy :), I really don’t mind sharing the model with you but I am so short on time… I have to get it finished today. let me try just figure out how to overcome the issue that i’m facing and hopefully I could show you the finished result… if I won’t make it I would appreciate your help…

So the issue is as follows: If I make a video of 18 (edited this number) seconds and my timeline is set to 80 ticks and in the Bongo options for 80 seconds, and at the end of the 18 (edited this number) seconds the object is still. It renders a video that by its end it starts to rotate again.

I do it by rendering a range of frames from 0 to 270 (which is 18 seconds times 15 fps)
I was also thinking the “0 second” could count so I tried frames 0 to 255 but then I think it still had a little movement at the end. I think that when I took it down to 0 to 225 frames (2 seconds less) it was ok, by then I got 2 seconds instead of 4 of a still video (that is was you mentioned you didn’t understand, sorry I might have not explained it so well).

Here are images of my settings and timeline:

Thanks a lot! :slight_smile:


And if we are here already :wink: are there any known ways to make the rendering of the frames faster?
in the current machine i’m using (which is not new) it takes about 2:20 hours to render 1200 frames in the size of 1920x1080. anything in the settings of rhino? in the objects? Thanks again.

Roy, sorry to have kept you waiting; I was off-line for a while.

On your Bongo Render Animation dialog I see that the Stop tick is 79. As I explained above, it has to be set to 80 in order to have 80 tick-periods (like the 10 cm of the ruler). I guess that’s what spoils all your calculations.

Secondly I assume you try to render the various fragments by using the Frames Range setting at the bottom of the dialog. For the first fragment (tick 0 to 18) the range has to be 0 to 269; being 18 x 15 minus 1 (because the 0 counts – as I explained above: frame 269 is the 270th)

But I feel all this scheming isn’t necessary.

To render the first portion you can simply set the Stop tick to 18, and the Length in secs. to 18. For the second portion set Start tick at 18 and Stop at 32 (I hope I interpret you goal and timeline image correct), and the Length in secs. to 14 (32 minus 18). Etc…

About speeding up rendering: I assume you use Rhino’s on board render module. Speed depends strongly upon CPU speed. Factor slowing down are:

  • Lights (the more the slower)
  • Antialiasing (to be found in the Document Properties/Rhino Render : lower = faster)
  • Mesh settings (to be found in Document Properties/Mesh)

Good luck and … courage.

Thanks @Luc, I suspected it might work like that :slight_smile: Thanks for the explanation, it will help for the future,
I’ve fixed it all in post… I was thinking about those “slowers” (though not about the lights) thanks.

so… I have some encoding to do and then you’ll see it :slight_smile:

Thanks again,


Hi @Luc, It took me a few more days to polish it, the text is in Hebrew, it was made for the “Jovella 2016” jewelry show that will be held next week in Tel-Aviv, Israel, where I will be also showing Rhino as I am an authorized reseller, certified trainer and a jewelry expert (so they say :slight_smile: ) so… enjoy… and maybe @scottd will like to see it too…

All models were made by me in Rhino (solely in Rhino). animation by Bongo and rendering by KeyShot also by me.
The first two rings are shown as a model in Rhino and then real pictures.
The last (yellow gold) pendant was shown also in two KeyShot renderings.

Full-screen (before playing) is A MUST :wink:

©All Rights Reserved. 2016.

I can make a “cleaner” version for the Bongo website if you wish.

1 Like

Please do Roy. The result is splendit - and “clean” enough in my opinion :thinking:.
Thanks for sharing.

Thank you @Luc. I’ll post it.