Text Editor Awfully Slow - Lags behind when typing

Hi people,

I recently noticed my text editor is super laggy when typing, even the cursor lags behind (it stays some letters behind before moving to the end).

Empty canvas, new document, up to date Rhino, up to date drivers, default text, 4 lines of text.
I’m attaching my system info.

Something I also noticed is that when moving the text object by dragging it, and instantly panning my view, I get the same lag.

Edit 01: no need to drag the text object, just by selecting it with click and panning the view lags, to the point the view moves after some seconds but the “hand” point never appeared.

Edit 02: typing in all caps seems to reduce the lag while typing as well as the lag from selecting and manipulating the text object

Thanks

system info.txt (2.1 KB)

No else is having the same problem? :sweat:

Hello - please try this with Vray disabled, and also with Properties not showing.

-Pascal

Thank you for the suggestions Pascal.

Disabling V-Ray had no effect on moving nor on typing.
Properties tab not selected did made a difference in selecting and moving text around, it made it light and smooth again.

Typing is still super slow.

Please make sure to update to the latest service release (6.28). I remember doing some work in this area in the last couple months

HI Steve, I just did and tested: no change.
I made a video to better convey what I am experiencing.

You can clearly see how the view lags behind when panning immediately after selecting a text object.
Typing also lags behind: for a moment no typing appears and the word appear instantly. Cursor also lags behind.

Any ideas guys? Is this only happening to me?

Hi @ShynnSup,

I can reproduce both of your issues and I created the following YouTrack items:

Thanks for reporting!

-David

2 Likes

Hello, I’ve been having this problem on and off for a few months too, and again this morning when editing a lot of text. I have the latest Rhino 6 build, latest GPU drivers, Win 10, etc.

Thanks,

Jonnie

Anyone got any news or workarounds on this please (other than closing the Properties panel)?

Sorry don’t know if this is an option but when I was doing layout for engraving pages I had to do it all in a text editor then copy/paste into rhino, was impossible otherwise due lags.
Open word pad or any other text editor and do your text in there then copy and paste into Rhino.
RM

Hi @DavidEranen ,
I see problems when using text in Rhino. Maybe you can just bring up word pad or something that works and then just copy paste into rhino? I see huge problems in lagging and formatting but text has been problematic since V5 so I gave up. But recently I did a small amount of text in V7 and noticed problems with lagging right off the bat.
RM

Thanks for the suggestion, it might end up being quicker even though I’m just editing a word or two (annotating 2D drawings).

Hi, is there a solution for this problem. I also have this Problem when working with annotaions in the Layout-Sheets.

@ShynnSup

  • How many monitors are you running and at what resolution?
    You only have enough VRAM for a single standard resolution monitor.
  • In Windows Conrtol Panel > Power options, are you set for High performance?
  • Are you using a docking station?

I’m working on an Asus ROG G751JY so:

One (1): 17.3" 16:9 IPS FHD (1920x1080) anti-glare.

No. But I tried it, no difference.

No.

I am not sure why these answers are relevant though as many users seem to experience the same with different hardware and software configurations.

I don’t think this is driver related. Have you tried this in the V7 WIP?

Yup, same thing. :frowning:

@ShynnSup, @barrento, @tgraph, @DavidEranen

Can you please try TestToggleSpellCheckOnAnnotationText and let me know if this improves the text editing issues you are seeing? Thanks

Hello Steve,

Thanks for this, I will try later today and report back,

Jonnie