V7 install nonsense

Really, why can’t this be fixed…?
V6 installs its updates with no problem…

Here’s the story now:

1] “An update is ready to be installed. Do you want to install it now?” = yes
2] “Platform not supported. Rhino requires 64bit Windows 8.1 or later.”
3] “No action was taken as a system reboot is required”
4] “No action was taken as a system reboot is required” - automatically (!) shuts down and restarts.
5] When the desktop icon is clicked, “Please wait… Updating toolbars etc…”
6] Rhino V7 starts and runs fine.

Please address this…

cheers
rabbit

1 Like

The AI from the computer gaming realm that has now infested all software development on Earth with computer game strategies means this is a feature and not a bug. It addicts you to whatever program you already own, so all developers except young entrepreneurs must follow this practice now, of making things work but only in convoluted fashion.

Are you running Windows 7? This may be the issue… Rhino 7 WIP no longer installs on Windows 7

This is fresh OEM windows 10, running on a dell laptop only a few months old…

It’s been like this for the last few wip installs; I’ve reported it before…

Cheers
rabbit

if that is the case you are likely in need of adding all the many updates that Windows needs.

hit windows update repeatedly until you are all up to date-

OK, here we go again…so, so boring…
Ive upgraded windows to 10 pro version 2004 - build 19041.388
Ive installed the latest nvidia drivers
Its exactly the same as before, so its either rhino, or something peculiar to this PC.
There is nothing odd or custom about the PC - its an off-the-shelf Dell laptop.

here’s the rhino system info:

Rhino 7 SR0 2020-8-4 (Public Build, 7.0.20217.03575, Git hash:master @ 31b1a3c260f17d78fb19ebf37e76b172f5dda99a)
License type: Commercial, build 2020-08-04
License details: Stand-Alone
Expires on: 2020-09-18

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Hybrid graphics system.
Primary display: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 5-19-2020 (M-D-Y).
Primary OpenGL: NVIDIA Quadro P3200 (NVidia) Memory: 6GB, Driver date: 7-13-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 451.77

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-13-2020
Driver Version: 27.21.14.5177
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Users\rabbit\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\ColorPicker\6.0.0\ColorPicker.rhp “ColorPicker”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7 WIP\Plug-ins\Commands.rhp “Commands” 7.0.20217.3575
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.0.20217.3575
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.20217.3575
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.20217.3575
C:\Program Files\Rhino 7 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.20217.3575
C:\Program Files\Rhino 7 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7 WIP\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”

Here’s the sequence:

it asks me if I want to install the update
It tells me this version of windows is not supported
it tells me nothing’s happened because a reboot is required.
it reboots automatically when I close that dialog
it starts up and runs fine.


Problem:
I’m using Windows 8.1/10, but the Rhino installer says my system is not supported.

Probable cause:
This problem is caused by Microsoft PCA (Program compatibility assistant). An earlier attempt to install Rhino was cancelled and the user responded to Windows that the program did not install properly, resulting in Windows PCA tagged it as an incompatible file.
Never respond Yes to this message.

Solution:

  1. Right-click on the exe installer
  2. Select Properties.
  3. Go to the Compatibility tab
    The compatibility mode may be set to and unsupported Windows version.
  4. Click the Change settings for all users button near the bottom.
  5. Clear the Run this program in compatibility mode checkbox.
  6. Click OK two times to close the dialogs.
  7. Right-click on the exe installer again and select Run as administrator to install.

Any luck?

Thanks John

The compatibility mode was set (I’ve no idea how, I don’t recall doing this).

So unchecking this then allowed me to install (7.0.20245.13385, 1/09/2020) when prompted.

However, I still get a dialog “No action was taken as the system needs to be restarted” or something similar, which repeats three times - ie it reappears when I close it.

Each time I close it, the red line indicating progress of the install advances a little, until after the third time the software finishes install, and the install complete dialog then prompts me to restart.

???

cheers

rabbit