V7 dimension style not sticking from radius dimension

V7 - if a dimension style is changed when first calling the linear dimension command, then subsequent dimensions are all in that new style.

However, if the dimension first called is a radial dimension, and it is changed to a different style, the change doesn’t stick… (which it does in V6).


Moved to Rhino for Windows.

Hi Rabbit - that seems to work as expected here in the latest. I make a few circles, start DimRadius, set the style to say Milimeter Architectural, make my dimension and then when I run the command again, the style is still Milimeter Architectural - that is what does not work for you, correct?


Hello Pascal

Yes, what you describe was the issue; however, I can no longer repeat it.

I could repeat it every time, which is why I posted it. At the time, before I posted, I opened V6 to check if that in fact was the default behavior, but V6 worked fine.
So back in V7 I again confirmed there was an issue, and then reported it.

At the time I had three other V7 instances running, and I didn’t think to check all of them were displaying the same issue.

I wonder if it might be something to do with “cross-talk” , where the last rhino standing sets some parameters for the next time the program is opened?

For example, toolbar position and display seems to take notice of that, and also somewhat annoyingly whether panels are opened or not – for example the notes panel I’d prefer to be an exception, since I only want it displayed on a file by file basis, not default to how it was last displayed.

I pretty much always run two to four instances of the program, mostly without any issues, but sometimes there is a bit of a hiccup depending on the order in which they are closed, if I don’t remember to close the one I want as the “master”.

Anyway, if it happens again I’ll report back.