Dimension style properties bug

select a linear dimension and I can change the style

select a radial dimension and I can change the style

select all dimensions and I can not change the style

Version 7 (7.2.20343.11012, 2020-12-08)
dim styles bug.3dm (2.8 MB)

Hi Abraham,

The way this work is not ideal. You have to select the same types of annotations in order to make changes, i.e., multiple radial dimensions or multiple linear dimensions. It works better on Windows but still not great. I’ve started an internal discussion on how to improve this.

Thanks for reporting it.

RH-62223 is fixed in the latest Rhino 7 Service Release Candidate

Hi Brian,

I am on Mac Version 7 (7.3.21012.11002, 2021-01-12) which Rhino tells me is the latest Service Release Candidate and I still can not see a dimension style in the Properties window when both linear and radial dimensions are selected. Windows works OK-I can select the dimension types individually in Properties to change style and that is fine.

Hi Abraham,

Multiple YouTrack issues were created to solve this problem and the one that Brian links to above is for the addition of these commands:


If only linear dimensions are selected then the ‘Linear Dimension’ tab will appear in the Properties panel letting you edit dimensions in groups instead of one at a time. Hopefully that will help until the real problem is solved.

The real solution is to have a single dimension tab appear in the Properties panel even when different dimension types are selected. Common properties will be at the top and others specific to the different types will be grouped at the bottom. Both Windows and Mac versions will work the same way.

Awesome! Thanks for your attention to this.