V7 Beta taking excessively long to save files

Is anyone else experiencing Rhino V7 Beta taking excessively long to save files? I noticed Rhino was taking long even for a ten meg file I just tried a 32 meg file and Rhino took 4 minutes to save. So I opened 3dsmax and loaded a heavy scene 346 meg and it saved in under a minute. Then in V7 I saved the 32 meg file as v6 file (which took 4 minutes to save) and opened it in V6 and saved it and it took 5 seconds to save. I’m not saving to an external or network drive.
BETA(7.0.20280.13133, 10/6/2020)

I recently updated windows due to service is ending warning.
Edition Windows 10 home
Version 2004
Installed on 10/8/2020
osbuild 19041.58

Never had this happen before and Rhino always beat out max for quickly saving in the past as well V6 is lightning fast saving the same file both V7 and V6 save file options had save textures checked and plugins checked.

Does that still happen with all non-Rhino plug-ins disabled?

Hi @nathanletwory I haven’t tried what do you want me to try?

Hi @nathanletwory,
Good call on disabling the non rhino plugins. I didn’t know we had that option as I see “start in safe mode” is no longer an option.

I had four non rhino plugins Songbird, twinmotion, nvidia denoiser, polyhedra
Disabled them and closed rhino, reopened rhino and rhino saved super fast again then I reenabled the plugins one at time and exited etc. then saved for each enabling and the lag was still gone. So now I have everything back to how it was but the lag is gone. I don’t know if disabling and reenabling is what helped or if there is something wrong with my laptop or if Windows was updating something behind the scenes.

Thanks for your quick help and suggestion.

Obviously some bit was flipped somewhere. When something like this happens for a dev or tech support internally you can be sure it will be dealt with swiftly. I certainly hadn’t seen awful save times like you reported.

In such cases it is useful for us devs to establish a baseline: is it in rhino core or not. Safe mode, or manually disabling plugins through tools » options » plug-ins is the he way to do that.

Good that it appeared to be one of the plug-ins. Bad that we now don’t know which one. It still could have been something in rhino itself, but it is not repeatable.

For now we can be happy that you are back in the fast lane.

Hi @nathanletwory,
I just updated to the latest V7 beta and right before updating I ran again into files taking excessively long to save. Then I exited and updated, reopened the same file and Rhino was saving again quickly, for instance 26 meg file under 4 seconds then all of a sudden after modeling and rendering Rhino again couldn’t save quickly I had to exit and reopen Rhino and now it’s back to saving the file at under 4 seconds. I don’t know if it’s rhino or something else. Maybe materials via web or something checking like the License manger or package manager. I didn’t disable plugins this time just exited and reopened Rhino and it’s working again.
I know you guys have your hands full just wanted to throw it out there in case.

To ensure this doesn’t go further uninvestigated I logged the issue as https://mcneel.myjetbrains.com/youtrack/issue/RH-61034

Thanks @nathanletwory I just opened the same file except with an added 10 meg and it’s saving in under four seconds again. Last night or morning I even tried clear all undos and still rhino took long to save. Seems like something creeps in as the session prolongs.

Hi @nathanletwory,
I’ve been trying to narrow this down and the one thing I am finding is that if I open a file and do not render the file saves quickly under 3 seconds. If I render the save times go up, going from under 3 seconds before any rendering to after rendering 1 minute. Also I can model and add geometry to the file and the save times are still under 3 seconds but if I render the save times instantly shoot up to one minute or more.
Maybe a memory leak or the rendered files are just eating the save time?

Also show last rendered for me doesn’t work I get a black viewport and no rendering displayed. Do I need to save the rendering first for this function to work?

What does rendering here mean? Using the Render command? So open file, use Render, then save file once render is done?

I have to investigate - I have never used this.

edit: I have logged this as https://mcneel.myjetbrains.com/youtrack/issue/RH-61122

Hi @nathanletwory

Yes that is what I mean and that is the procedure for me to make the long save file time occur.

Also I found if I open the file, render but cancel the render, the file still saves quickly. But if I let the file render completely and then save the file after rendering the save takes over a minute or more compared to under 4 seconds.

If I only do modeling and even add to the file making it larger the file still saves quickly but once I do a complete render the file save goes back to over a minute or more.

Also I tried switching cycles in options from gpu to cpu and that had no effect.
Thanks for taking a look at the show last rendering command (that looks completely broken), and for your help.

Ok,thanks forthe information. I will do some testing here wrt the save speed issue.

@3dsynergy I have not been able to reproduce saving slowness. I assume you have plug-ins not shipped with Rhino enabled? I tested with the denoiser plug-ins loaded, but I don’t have the other plug-ins you mentioned.

Hi @nathanletwory,
Thanks for trying to replicate this. It’s really bad for large files. But even small files do this and new files. Files that take 2 - 4 seconds depending on size begin to slow down right after rendering. Although going from 2 seconds (for a 12 meg file) to 14 seconds is not that noticeable it gets worse for large files and quite perceptible.

I’ve disabled all non rhino plugins and only left the Nvidia denoiser and it’s still happening.

If at some point if you have time I can send you a video and or file of it happening as these files are nda or we can do a remote session. I know you guys are swamped with real work so I’d hate to have it be something stupid on my side. Let me know.

Thanks for your attention and help.

I’ll let you know in a pm.