Taking forever to save / Slow save times

Hello everyone,

Recently (?) my rhino files are taking forever to close/save and I dont know why.
Do you have any idea why so? I’ve google this but seems like I cannot find the issue.
This is for all my rhino files, smaller (135 kb) like 1-2 minutes and larger, I dont even know…

Thank you!

Rhino 7 SR12 2021-11-9 (Rhino 7, 7.12.21313.06341, Git hash:master @ 5590153808223b57a9f41516a969fd949aa81bff)
License type: Educational, build 2021-11-09
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 15Gb)

Computer platform: LAPTOP - Unplugged [21% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: AMD Radeon™ Graphics (AMD) Memory: 1GB, Driver date: 9-16-2020 (M-D-Y). OpenGL Ver: 4.6.13596 Compatibility Profile Context 27.20.11041.2001
> Integrated accelerated graphics device with 6 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 9-16-2020
Driver Version: 27.20.11041.2001
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 512 MB

Rhino plugins that do not ship with Rhino
C:\Users\w1739527\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\IntelDenoiser\0.6.4\IntelDenoiser.Windows.rhp “IntelDenoiser.Windows”
C:\Users\w1739527\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\ProRender\\ProRender.Windows.rhp “ProRender”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

File: DES3A_Gatehouse_REV1.3dm - Google Drive

Thank youuuuuuuuuu

Are you saving to a network drive?

Perhaps you could try updating Rhino, there are quite a few service releases newer than what you’re running.


No, I am saving to a USB.
Yes, I tried to update Rhino, however, it doesnt work, probably it has something to do with the fact that I am working on a corporate computer (uni computer), and yeah, idk…


Opened the file you linked to above (53.7 MB) moved some geometry and saved - seemed pretty quick (a couple of seconds at most).

Same results here on Windows and MacOS (both @ Rhino version 7.20).

If you’re saving to a flash drive, some of them can be pretty slow. Have you tried saving to the local hard drive (or a different USB drive) to see if it is faster?


Like a USB stick? They’re terrible.

Your graphics have very old drivers and don’t meet minimum requirements to run Rhino, especially not plugins like ProRender.

Okay so I moved the files to the local hard drive and it worked much faster… So I guess its solved then! The USB has worked perfectly fine, well, until somewhat recently… Ill continue to use the hard drive…

Thank you!

Yes, it worked when I moved the file from the USB to the local hard drive.
Yeah I know the specs on this computer arent the best but its a uni computer so I cant do much about it… soon to graduate anyway…