V6 updater not working on my machine


#1

The updater crashes on my machine whenever I click “Yes” on the “Update Available” dialog (either at Rhino startup or exit).

It leaves behind a file “RhinoDotNetCrash.txt”.

I’ll attach the crash file and my system info.

Thanks,
John

RhinoDotNetCrash.txt (4.5 KB)

system_info.txt (1.7 KB)


(Brian Gillespie) #3

Hi @ajohnblack,

That crash should be fixed in SR3, which of course you are trying to update to. To get SR3 without going through the update system, please visit https://www.rhino3d.com/download/rhino/6/latest

Please let me know if you still get this crash when the next update comes out.


#4

Hi Brian,

I got an update today and it looks like the problem is still there.

John
RhinoDotNetCrash.txt (4.5 KB)


(Brian Gillespie) #5

@curtisw do you have any idea what’s going on with this .NET call stack?


(Wmc) #8

Not sure if this will help but when I updated my version rhino_en-us_6.4.18107.01041 to version rhino_en-us_6.4.18114.15591 the install reported a folder permission problem and then locked up. I ran the repair install option and it loaded another version of .NET on my computer (required but missing I assume), and then continued to a successful install.


(Curtis Wensley) #9

Hm, looks like Eto’s trying to resize the icon to a zero (or less than zero) width or height for the notification dialog. Not sure exactly why that is as it shouldn’t happen looking at the code. It might have something to do with setting the image after the form is created, but why others don’t get the issue is beyond me if that is the case.

I can think of potentially one thing that may be causing this, so I’ve created a YT issue to look into it.