Rhino 6 crashing after Win 10 update

I just updated my desktop to Windows 10 Pro ver 2004 from ver 1909. Now when launching Rhino 6 sr 34 if I click on the splash screen icon for the file I want to work on, rhino churns for a moment as if loading the file the closes. The is no crash dump file. When I attempt to launch a second time it works as expected. This behavior has repeated numerous times over the past couple of weeks.
My system info →
Rhino 6 SR34 2021-2-3 (Rhino 6, 6.34.21034.07001, Git hash:master @ 2fec8130f097ca52a8bc9f334c3ed4a5921c5e30)
License type: Commercial, build 2021-02-03
License details: Cloud Zoo. In use by: Robert McDougle ()

Windows 10.0.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: HEPHAESTUS

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 970 (NVidia) Memory: 4GB, Driver date: 3-25-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 465.89
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-25-2021
Driver Version: 27.21.14.6589
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.34.21034.7001
C:\Program Files\SimLab\Plugins\SimLab 3D PDF From Rhino 6\plugins\SimLabPDFExporter.rhp “SimLab PDF Exporter”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp “Named Position”

If the 2004 update broke something, have you tried running Windows Update for subsequent patches to it? (Or the autumn release, 20H2?).

I did just now run update and found a few. I updated to most current builds but the problem remains. I don’t see the autumn release, 20H2 as available for my system. Thanks for your input.

Hi - have you tried repairing the Rhino installation?
-wim

Repair fixed it. That sequence also repaired .Net 4.5 as well. Maybe that is what got munged in the windows update.
Many thanks…