V6 Raytraced Viewport -- Default To Hard Shadows?

Is it correct for Raytraced Viewport to display hard shadows as default?

I don’t remember it doing that, but now seems to show hard shadows even after resetting rendering…



What kind of lighting are you talking about? Does it happen with a simple box and groundplane? If so please attach that simple 3dm

Hello - check to see if the skylight is on in the Lights panel- you can also open the Render panel and click ‘Restore defaults.’
Any luck?


Hi Cal-

I’ll post a pic. If I open a new scene and create a cube and set the viewport to Raytrace…it produces a hard shadow. If I set the viewport to rendered it produces a soft shadow.

When I set the viewport to raytrace and “restore defaults” it momentarily displays a soft shadow and then immediately switches back to a hard shadow — which doesn’t seem correct.

If I then go into the viewport settings for raytrace and look at the “shadow” settings specifically it shows the shadow box checked at the top. If I toggle the box off, which should allow control of the shadow settings, they are grayed out, which doesn’t make sense.



Hi Jim -I could not remember for sure if you’re handle was ‘jvm’ - I had my suspicions though… Can you run the SystemInfo command in Rhino? Does the raytrace continue to refine as expected?


Thanks Cal-

Here’s My System Info.

Rhino 6 SR11 2018-12-14 (Rhino 6, 6.11.18348.17061, Git hash:master @ 600b621e607cf5226a968db60d7ac9230541b94d)
Licence type: Commercial, build 2018-12-14
License details: Cloud Zoo. In use by: jvm ()

Windows 10.0 SR0.0 or greater (Physical RAM: 64Gb)
Machine name: MSI

GeForce GTX 1070/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 382.05)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 5-1-2017
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi Cal-

Here’s a default scene with a single block, viewport set to raytrace, same look if I “reset to defaults”


simple_cube_raytraced_viewport_001.3dm (37.3 KB)

Doesn’t get any more basic than this – cube with default groundplane.



Hey Jim - background/environment is set to Solid Color.


‘Reset to defaults’


should set that to ‘360 degree Environment’ > ‘Studio’, I think, - but you can set it explicitly as well.


You don’t have sun nor skylight, nor any other lights. You get a camera-based directional light that gives hard shadows. Turn on the skylight to get the soft ones.

No need to use a different background, altough it will help in getting better accents on the objects.

Thanks Pascal / jesterKing

Apologies for delay in getting back…I tried settings as both of you suggested and still had a hard shadow.

To fix it I went into Display Options => Restore Defaults and was then able to set skylight and custom background.

“Reset To Defaults” from the Rendering Tab is not the same as Restore Defaults in the Display Options.

Thanks again.


Hi @pascal I am also having trouble with shadows in Rhino 6 raytrace view.

When I create a simple test cube in a small file the raytrace view shadows appear as expected and i’m happy.

However, I am working on a massing model at urban scale and would like to create simple shadow visualisations from different viewpoints to test different building densities. My model file size is large (176MB) due to urban planning linework I think.

Using ‘rendered’ view it works - the shadows are point in accurate direction (according to sun time of day) and I am able to edit what the shadows look like via Rhino Options - Display Modes - Rendered.
Using ‘raytraced’ view it doesn’t seem to work - the shadows appearing on faces sometimes appear to be wrong (according to the sun time of day) and do not appear to be cast on the ground (or if they are it is extremely feint to the point that it can’t be seen). I note that doing: Rhino Options - Display Modes - Raytraced - Shadows - it is greyed out and I can’t change anything.

I know that exporting to Sketchup could work for shadows but I would much prefer to keep my workflow all within Rhino.

Is this a known issue/any tips that I should try? Thanks for your time.


I suppose the secondary lighting is filling in - not super predictably from the viewers standpoint, but probably depending on polygons and scale - @nathanletwory will know.
I’m not sure what raytrace will get for you that Rendered cannot, even if it ‘works’.


If you want to do this kind of “dark” shadows (i.e. no diffuse lighting into shadows) then you should go to Tools > Options > Cycles and set diffuse bounce to 1. Further in the Lights panel turn off skylight, because it is also filling your shadows .

edit: if you set diffuse bounce to 0 you get something very close to Rendered mode.

Here a file created with Rhino WIP (v7)

0_diffuse_bounce__strong_sun.3dm (4.5 MB)

This gives nice black and hard shadows from the sun. Note there is no skylight used. Diffuse bounces set to 0. Sun intensity increased (possible in v7)

1 Like

Hi @pascal @nathanletwory
Thanks for your responses.
I worked out why shadows weren’t working accurately for me in raytraced mode - I think the combination of a very large file size and it being in the ‘real world’ GIS location (very far from origin) was causing problems. I moved it to the origin and they are showing accurately now.
Posting this in case anyone else has the same problem. Thanks again.

1 Like