Shadows options disabled in Raytrace

I wanted to try and soften the shadows in Rhino Raytrace but the Shadows Options are disabled, even though “Shadows On” is checked. Am I missing something?

Raytraced doesn’t use the OpenGL settings for shadows.

What do you mean with softening of shadows? Less sharp borders?

Yes, exactly.

Shadow softness control hasn’t been exposed yet.

So at some point, this screen will be active?

I don’t know yet. This particular screen is for OpenGL-type shadows, not sure how it fits with that. More likely is some type of options for an active view, or even more likely in Tools > Options > Cycles

OK, thanks.

Potentially earlier with some advanced setting under Tools > Options > Advanced. Probably different global-ish softness settings for the different light types.

Even better would be per-light in document control for shadow smoothness.

1 Like

Try using a rectangular light and change it’s size and distance from the model.

1 Like

That will work as a work-around indeed.

I used a couple of rectangular lights on either side of the object, and it looks pretty good, although, of course, now it doesn’t jump out at you the way it did when the shadows were crisp. You know what would be nice, if Rhino had some default lighting templates to produce certain effects, like a jewelry display or car ad.