V6 and V7 Layout Technical does not hide objects behind other surfaces which they touch

Hello. This is similar to V7 Layout Technical does not hide objects behind other surfaces.

However, it is a different problem. That earlier problem exists in V7, but not in V6. This problem exists in V6 and V7.

In a Technical view on a Layout, objects behind which are trimmed by an object in front are showing through the front object.

In the attached model, the gable objects should not be seen through the flat roof object.

Regards, Garry.

Rhino 6 SR33 2020-12-5 (Rhino 6, 6.33.20340.21001, Git hash:master @ dc3074cfd26cb57b879a6e486e45c2af932a7620)
License type: Commercial, build 2020-12-05

Rhino 7 SR2 2020-12-8 (Rhino 7, 7.2.20343.11011, Git hash:master @ d3289272aab6acdf2cb6aaf1869cd9a2d8cb464c)
License type: Commercial, build 2020-12-08

HouseRemodelZHTP3ap3V6Problems.3dm (6.2 MB)

Hi Garry -

When I open the file that you attached here, I see this:

I’m not sure what the “flat roof object” refers to and which gable objects shouldn’t be seen here.

Hi Wim. In the first image I have selected the Gables objects.

In the second image I have selected the Flat object.

The problem appears on Layout Page 3, but it also appears on the primary views in Technical mode.

The Gables objects were trimmed by the Flat object, so the upper edges are in the same corrugated plane as the Flat object, but to be true to its purpose, the Technical view should regard the Gables objects as behind, and hide them from the view, except where they are not behind, such as in the 3 Front and Back Details on Page 3, and the lower portions of the Gables objects on the Right and Left Details on Page 3.

It is best demonstrated in the Perspective below. Technical correctly hides the portions of the Gables objects which are behind the Flat object, but the upper trimmed edges of the Gables objects are shown. Could it be that the Gables objects slightly protrude through the Flat object, even though they were trimmed by it? That seems to be confirmed by a slight move upwards of the Flat object.

To test the trimming with simple flat surfaces instead of with the extruded corrugated surface, I have added a new Simple layer to the model and retrimmed the Gables objects with the Simple object. That did not help.

I then created a new surface from the edge of the Simple object. Its edge also shows through the Simple object in Technical view, so the problem is not as a result of the trim operation.

I found the documentation below. It seems to suggest that intersections are displayed. However, The line that bothers me is the top edge of the surface, which is not removed when I change Technical to omit Intersections.

With Show Intersections:

Without Show Intersections:

If edges in the same plane as objects in front are intended to show ‘through’, then I will have to trim the surfaces below the objects in front. Would it be possible to provide an option to hide such edges?

Later… I have trmmed the Gables objects lower. That will be OK for now. Thank you for your help.

HouseRemodelZHTP3ap3V6Problems.3dm (6.2 MB)

Regards, Garry.